It's all about the answers!

Ask a question

Getting error: Invalid path to authentication servlet.: /


Kaushambi Singh (37139979) | asked Feb 05 '14, 6:23 a.m.
Hi,
I have installed CLM 4.0.5 and using WAS 8.5.0.1 . WAS is running fine and I faced no issues in installing CLM.
I am getting this error while logging to CLM (http://localhost:9080/jts/admin). If I type only till /jts, as soon as I login,I get this error:Invalid path to authentication servlet.: / and if I type till /admin, the page is held with loading.... message.
I saw the similar post (https://jazz.net/forum/questions/82881/login-issue-invalid-path-to-authentication-servlet) but it doesn't have the resolution steps. I tried on firfox,IE 8, IE 10, Chrome but the error remains same. Could someone please help on this ?




One answer



permanent link
Sumant Renukarya (1.1k23339) | answered Feb 05 '14, 8:41 a.m.
Hi Kaushambi

--> I believe you should raise a PMR for this with IBM Support for detailed investigations. 

--> In one of the previous instances, where the issue was only specific to Internet Explorer, adding the following registry key 
did resolve the problem:

***

Force Shell Execute:

32-bit:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet  "ForceShellExecute"=dword:00000001 
 
64-bit:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet "ForceShellExecute"=dword:00000001

***

--> More details about this Force Shell Excecute key, as per Microsoft: 

1 – Why does this fix the problem? 

Office will by default use Urlmon which is the URL monikers library that ships as part of IE (windows) to bind the URL supplied in the link to a moniker to allow it to access the object that it represents 

http://msdn.microsoft.com/en-us/library/ms775150(v=VS.85).aspx 

Take a look at: 

838028 How documents are opened from a Web site in Office 2003 

http://support.microsoft.com/default.aspx?scid=kb;EN-US;838028 

By setting the forceshellexecute setting, Office will use the operating system function ShellExecute to access it instead and thus use the default browser as the article states.  The reason why this fails is that the proxyserver is giving back a 403 code due to either IE not being allowed or not allowing http traffic on the local file system depending on the link. 

2 – Why is this old legacy Office setting (Office v9) still impact what v12 and v14 are using? 

The version of Office and registry key indicates 9.0 because it was written for HLINK.DLL not directly to a version of Office. Therefore, it applies to Office 2007 indirectly because it changes the behavior of the file that controls hyper linking. 

3 – Does enabling this setting reduce security etc.? 

Using the setting is pretty much the same as opening the link from the RUN dialog. So my opinion would be no unless they had some other security issue that made using the RUN dialog more vulnerable than opening the link via IE 

4 – Is this a bug in the product (IE)?
 
No, it's not a bug, simply a limitation of using the http protocol through Urlmon with a proxy restricting traffic. Office has really nothing to do with it. Urlmon makes the request for URL and the proxy returns an error thus it fails.


Comments
Sumant Renukarya commented Feb 05 '14, 8:54 a.m.

Adding, I am not sure if you have seen this article. Might help:


 


Kaushambi Singh commented Feb 06 '14, 1:35 a.m.

Thanks Sumant for replying. I actually avoid as its really takes lot of time. If you see the link which I have posted (https://jazz.net/forum/questions/82881/login-issue-invalid-path-to-authentication-servlet), it does mention change in LDAP setting worked for that user but then the details are not mentioned. Any idea on the LDAP setting related changes on this ? Somehow I feel this is something to do with LDAP.

Your answer


Register or to post your answer.