It's all about the answers!

Ask a question

What are possible causes for RTC 4.0 performance issues ?


Prasad Annamdasu (15453543) | asked Oct 26 '12, 2:24 a.m.
edited Oct 26 '12, 4:27 a.m.
 Hi, 

I am trying to setup RTC 4.0 in a VM environment using DB2 and WAS. 
The VM has 4 CPU Quad-core 2.4Ghz and 16GB RAM.
Installed and Configured as per the IBM documentation, applied the fine-tuning settings to the DB2 and WAS. 

Able to access the WAS admin console with no delay, but  when i try to access the RTC in web it takes 5 min to load each page.

The same installed in my laptop, where i don't see these issues. It is working perfect.

Need help on this . 




4 answers



permanent link
Scott Rich (57136) | answered Oct 26 '12, 7:05 a.m.
JAZZ DEVELOPER
 WhenI hear "minutes" for response times, I'm reminded of this issue with DNS resolution in limited networks: https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=216290

Is it possible this is what you're seeing?

Scott

Comments
Prasad Annamdasu commented Oct 26 '12, 11:47 a.m. | edited Oct 26 '12, 11:55 a.m.

 Hi Scott, 


Thanks for pointing me to the information. 

I am facing this problem in a production environment. 
Where my DNS servers are configured as per the best practices. 

Is this problem fixed in 4.0.0.1 ?




permanent link
Arne Bister (2.6k12732) | answered Oct 26 '12, 3:49 a.m.
JAZZ DEVELOPER
Hi,

firstly, could you please change the title of this topic to a question? It would be more appropriate to read something like: "What are possible causes for RTC 4.0 performance issues using browser XYZ?"

One thing I have observed in the past: if you are using Internet Explorer and you have no valid SSL certificate (or a self-signed certificate that you have not put into the trust store yet), the browser will behave really slugglish. Can you test if Firefox is behaving differently? If you make a self-signed certificate and put it into your trust store, does performance improve?

To find out more, please go to the project Dashboard, add widget and search for "performance". You will find the performance health measurement widget. Add, run and see if there are issues.

You can also use the Eclipse client and the Metronome to find the root cause, which calls are causing the performance issues.

- Arne

Comments
Prasad Annamdasu commented Oct 26 '12, 4:40 a.m.

Hi, 


I want to clarify on the browser part, i am currently using the firefox. 
Added the self-signed certificate to the trust store. 

I added the Performance health measurement widget and details are as below

Round trip Latency:  Avg : 56ms, Max:64, Min:44, Standard deviation: 10. 

Database Latency  : 0ms

Download Speed : 14075 KB/s

Upload Speed : 24526 KB/s

I don't find anything critical here.  

-Prasad


Arne Bister commented Oct 26 '12, 4:48 a.m.
JAZZ DEVELOPER

Hi Prasad,

the results show that the server / database connections are great.
Are you measuring from a browser started ON the server?
What are the measurements from a browser on a client pointing to the server?

It seems that the performance issue is likely with the browser and the javascript (the widgets etc. are basically javascript). Popup-blocker, Virus Scan, Browser plugins ... any of these are likely candidates I would look into.

- Arne


Prasad Annamdasu commented Oct 26 '12, 5:28 a.m.

 Hi Arne, 


I ran the test in the widget from the client browser, there is no major difference in the values mentioned in the previous post. 

Java script is enabled in the browser. 

-Prasad


permanent link
sam detweiler (12.4k6181201) | answered Oct 26 '12, 3:05 p.m.
at least for me, V2.x and 3.x worked just fine.. 4.x was very slow, like u mention..

turned out the DNS function in my router was having trouble, and some change in the RTC code (server rename?) caused a significant number of new DNS lookups..

fixing the DNS problem fixed my RTC 4 performance issues.

Sam


Comments
Prasad Annamdasu commented Oct 26 '12, 5:30 p.m.

sam detweiler
 

Hi Sam,

What changes you made in your DNS ?
Can you pls explain on this.

Did u removed the unwanted lookups ?
like 
net.jazz.web.ui
net.jazz.web.app



sam detweiler commented Oct 27 '12, 6:26 a.m.

I changed my router config to explicitly specify a dns server address, instead of passing the ISP provided address. I did not change any RTC config


permanent link
Davyd Norris (2022914) | answered Oct 27 '12, 12:21 a.m.
I have seen very similar performance issues in my demo environments.

I have CLM 4.0 installed in a VM, and have found that depending on my external network connection outside the VM, my internal performance of the CLM server will change.

I have also found that RTC Eclipse client connectivity doesn't ever seem to be affected, it's only when I use the web UI. I'm running Tomcat and Derby with lots of RAM and nothing ever shows as being under stress, when I am waiting for the browser the CPU load is nearly zero and the processes seem to be almost dead, like it's waiting for something...

I find it particularly on the first access - the certificate warning comes very quickly, but then it takes forever to show the "Loading..." page, and forever again to show the login screen, and then forever again to show the first dashboard. If I keep going it seems to get faster but I have had to abandon several demos because of it - very embarrassing!!

Comments
Davyd Norris commented Oct 27 '12, 12:28 a.m.

I just read the above Work Item:

https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=216290

This is EXACTLY what I see, right down to the conditions for network and the Eclipse client behaviour.

Your answer


Register or to post your answer.