It's all about the answers!

Ask a question

CLM v4.0.4 Enterprise deployment finalization problem with application servers


Mark Blaschke (1636) | asked Nov 21 '13, 3:31 a.m.
edited Nov 21 '13, 3:02 p.m. by Lisa Caten (342913)
I've setup an Enterprise Deployment of CLM.
RQM and CCM are on two seperate servers, JTS and RRC are on the same server.
Each app has it's own WAS Profile on their respective servers.
The Reverse proxy servers is IHS, it appears to be working as designed.
IHS, JTS, RM on gccsrat01
CCM on gccsrat02
RQM on gccsrat03
I can use gccsrat01 to see the Admin page of all three applications (JTS/CCM/QM)

The problem comes during JTS setup -
I can register all the applications, but when I go to Finalize CCM or RQM  - nothing - the button never goes active.
I've removed each app and tried just the one (remove CCM and register RQM), and same result.

Both get the following entry in the log file:
org.eclipse.core.runtime.AssertionFailedException: null argument:The local application's root services could not be fetched, contained invalid content, or was missing the required entry for jfs:oauthDomain

The URI I get for the fetch, from qm.log is this:
https://gccsrat01.dev.psegliny/jts/discovery?type=http%3A%2F%2Fjazz.net%2Fns%2Fui%23HomeMenu&scope=includeExternal

If I run this into the browser I get the following:
<rdf:RDF><j.1:HomeMenu><dc:publisher>gccsrat01.dev.psegliny/jts</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:service rdf:resource="https://gccsrat01.dev.psegliny/jts/home-menu-dashboard"/><j.1:menuSection rdf:resource="http://jazz.net/ns/ui/menuSection#dashboard"/><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/jts/application-about"/><jd:contextRoot>https://gccsrat01.dev.psegliny/jts</jd:contextRoot></j.1:HomeMenu><j.1:HomeMenu><dc:publisher>/admin</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:service rdf:resource="https://gccsrat01.dev.psegliny/admin/home-menu-contribution"/><j.1:menuSection rdf:resource="http://jazz.net/ns/ui/menuSection#admin"/></j.1:HomeMenu><j.1:HomeMenu><dc:publisher>/qm</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:service rdf:resource="https://gccsrat01.dev.psegliny/qm/home-menu-project?path=web/console/"/><j.1:menuSection rdf:resource="http://jazz.net/ns/ui/menuSection#project"/><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/qm/application-about"/><jd:contextRoot>https://gccsrat01.dev.psegliny/qm</jd:contextRoot><j.1:defaultIcon rdf:resource="https://gccsrat01.dev.psegliny/qm/web/com.ibm.rqm.planning.web/ui/internal/page/templates/images/banner/RQM_16.png"/></j.1:HomeMenu><j.1:HomeMenu><dc:publisher>/rm</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:service rdf:resource="https://gccsrat01.dev.psegliny/rm/discovery/home-menu"/><j.1:menuSection rdf:resource="http://jazz.net/ns/ui/menuSection#project"/><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/rm/application-about"/><jd:contextRoot>https://gccsrat01.dev.psegliny/rm</jd:contextRoot><j.1:defaultIcon rdf:resource="https://gccsrat01.dev.psegliny/rm/web/com.ibm.rdm.web/pages/images/RRM_16.png"/></j.1:HomeMenu></rdf:RDF>

The URI I get for the fetch, from the ccm.log is this:
https://gccsrat01.dev.psegliny/jts/discovery?type=http%3A%2F%2Fjazz.net%2Fxmlns%2Fprod%2Fjazz%2Fdiscovery%2F1.0%2FApplication&scope=includeExternal

If I run this into that browser I get the following:
<rdf:RDF><jd:Application><dc:publisher>/qm</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:contextRoot>https://gccsrat01.dev.psegliny/qm</jd:contextRoot><jd:registration rdf:resource="https://gccsrat01.dev.psegliny/qm/service/com.ibm.team.repository.service.internal.setup.IRegistrationHandlerService"/><jd:domain rdf:parseType="Resource"><dc:identifier>http://open-services.net/ns/qm#</dc:identifier></jd:domain><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/qm/application-about"/><jd:rootServices rdf:resource="https://gccsrat01.dev.psegliny/qm/rootservices"/></jd:Application><jd:Application><dc:publisher>/rm</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/rm/application-about"/><jd:contextRoot>https://gccsrat01.dev.psegliny/rm</jd:contextRoot><jd:rootServices rdf:resource="https://gccsrat01.dev.psegliny/rm/rootservices"/><jd:registration rdf:resource="https://gccsrat01.dev.psegliny/rm/configureRegistration"/><jd:domain rdf:parseType="Resource"><dc:identifier>http://open-services.net/ns/rm#</dc:identifier></jd:domain></jd:Application><jd:Application><dc:publisher>gccsrat01.dev.psegliny/jts</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:contextRoot>https://gccsrat01.dev.psegliny/jts</jd:contextRoot><jd:rootServices rdf:resource="https://gccsrat01.dev.psegliny/jts/rootservices"/><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/jts/application-about"/></jd:Application><jd:Application><dc:publisher>/admin</dc:publisher><jd:scope>http://jazz.net/xmlns/prod/jazz/discovery/1.0/internal</jd:scope><jd:contextRoot>https://gccsrat01.dev.psegliny/admin</jd:contextRoot><jd:rootServices rdf:resource="https://gccsrat01.dev.psegliny/admin/rootservices"/><j.0:publisher rdf:resource="https://gccsrat01.dev.psegliny/admin/application-about"/><jd:systemApplication>true</jd:systemApplication></jd:Application></rdf:RDF>

At this point I have no idea.

Comments
Ralph Schoon commented Nov 21 '13, 11:01 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Mark, can you check if you can reach CCM and QM by their root https://gccsrat01.dev.psegliny/ccm/ or the root services https://gccsrat01.dev.psegliny/ccm/rootservices ?

What confuses me is, that you seem to be able to configure them, but then the last step does not work. Usually, if you have an issue with the WAS profile e.g. typo in JazzHome, you should not even get that far.

Accepted answer


permanent link
Mark Blaschke (1636) | answered Nov 24 '13, 4:41 p.m.
Agree Ralph,
And after a lot of searching and some nail biting - found the problem.
I had mis-typed the keyring and stashfile names in the plugin-cfg.xml file

Of course this prevented any authentication from working. With the correction and restart of IHS all is good in CLM land.
Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Nov 25 '13, 4:20 a.m. | edited Nov 25 '13, 4:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I am glad it is working for you now. I think this whole infrastructure stuff is adding a lot of flexibility, but also so much complexity. This makes it sometimes hard to get going. It is also very hard to nail down the root cause. Regardless how good the documentation is, there is nothing that protects you from typos. I remember a colleague in a workshop where we couldn't perform a login after an upgrade. After staring at the screen and pulling our hair out we finally found a Typo in JAZZ_HOME. 8-)
 

One other answer



permanent link
N Z (3621826) | answered Nov 21 '13, 4:26 p.m.
We had a similar problem. We could do the whole install, except the finalize. We had a PMR open and it went on for quite a while, but to summarise, it was a combination of using secure and non-secure protocols between the various network elements. Although it should have worked (according to IBM), it never did. (if I remember, CLM did not behave in a consistent or logical manner!). Not sure if this is the same problem, our network was a little more complex, and we were using ssl offloading. but we had similar redirects when we had our problem that you had, i.e.,
 
https://gccsrat01.dev.psegliny/jts/discovery?type=http%3A%2F%2Fjazz.net%2Fns%2Fui%23HomeMenu&scope=includeExternal 

Note the https/http redirect. The upshot was that support told us we should use https or http all the way through. Since you are accessing via https, check that you use the secure port between IHS and WAS, the certs are applied and your plugin is correct.

Your answer


Register or to post your answer.