It's all about the answers!

Ask a question

Unable to hit the web URI during installing CLM 4.0.4


Daniel W (13710) | asked Oct 11 '13, 11:19 p.m.
 We are installing the entire CLM suite, IBM Http server, as Websphere.
We are having issue with http server. After successfully moving the keystore from http server root to temp folder on windows, we are able to see the port 443 is listening by using netstat -na command.
However, when we type in the URL in the IE browser, we see page can't be displayed message on the server box. I am no http server expert.
Any idea what might causing it?

Comments
Daniel W commented Oct 12 '13, 12:27 a.m.

Straightly, the original DNS name (fully qualified) can bring the http server home page.

The virtual host I setup couldn't display.
I added one line in the Hosts file in system32 folder. and wrote down clmserver1.fxgovt.com after the IP.

I uncommented the ServerName in httpd.conf as what I've added in hosts file.

But when I typed clmserver1.fxgovt.com, displays nothing.
Instead the original name is ok. Not sure why. 

4 answers



permanent link
Indradri Basu (1.8k1514) | answered Oct 12 '13, 4:14 a.m.

Have you tried accessing the CLM applications without using the IHS ? Is it a single application server deployment or distributed ? What are the versions of WAS/IHS you are trying with ? Have you set the Web container properties ? Yes, it does sounds like your IHS is not routing request to where it should. If you post what you see in the WAS/IHS logs you may get better answer here.

However, I am assuming you are following Configuring Enterprise CLM Reverse Proxies: WebSphere 8 and IHS 8 but if not then you probably should as there are some addtional configuration that are required for IHS to work which are mentioned in the topic page.


Comments
Daniel W commented Oct 16 '13, 3:12 p.m.

I guess I may have to change to a single application server due to the limited resources. Also, I am trying to use IIS instead of IHS for webserver. Could this be done?

On the issue at hand, I can use the snoop function to see the https://clmserver1.fxgovt.com:9443/snoop, but I can't use it for http://clmserver1.fxgovt.com/snoop.


Kot T. commented Oct 16 '13, 3:52 p.m.
JAZZ DEVELOPER

I assume 'clmserver1.fxgovt.com' is your webserver (not the servername). Based on the results above, you can access the snoop application via the webserver thru https port 9443, but not http (not sure if this is a typo) on port 80 (or 443 if https). What port is your webserver listening on? I do not know IIS, but if IHS, it's in httpd.conf.


permanent link
Abraham Sweiss (2.4k930) | answered Oct 14 '13, 8:27 a.m.
I suspect the WebSphere plugin has not been installed.  This can be verified by reviewing the httpd.config and searching for "plugin"  There should be two load arguments, one loading the plugin module and one loading the plugin-cfg.xml (This file contains the routing information used by the webserver  to get requests to the appserver)

Comments
Daniel W commented Oct 16 '13, 3:13 p.m.

plugin was installed. And plugin-cfg.xml was propagated.


permanent link
Abraham Sweiss (2.4k930) | answered Oct 17 '13, 4:24 p.m.
>Since IIS uses the WAS plugin, it should work.
>I suspect that port 9443 is the WAS port, and hitting it directly works fine.
> WHen the request fails, i would look in the webserver access logs to see if there are any errors or 404 responses

At this point, if there is a dead line looming, may be a good idea to open a service request with IBM.  This way we can review the configuration, vew logs and  see help with the configuration.



permanent link
Indradri Basu (1.8k1514) | answered Oct 18 '13, 8:26 a.m.

Hi Daniel,

I don't see IIS in the system requirements page so to me it seems what you are trying is an unsupported configuration.

However, if you are using network deployment version of WAS then there is another option to setup a reverse proxy using WAS ND Proxy. You can find the information here.

Your answer


Register or to post your answer.