It's all about the answers!

Ask a question

WorkItem Queries property settings under Advanced Properties no longer visible


Heike Spayne (31) | asked May 15 '17, 5:52 p.m.

 Hello,


for a quick testing purpose, I changed the "Full Text Merge Limit" setting under WorkItem Queries on my server's Advanced Properties settings for CLM. I changed the default value from 100 to 1000. I completed my test and now want to change the setting back to 100 - but the entire Workitem Queries property setting section is no longer visible.
What am I missing? How can I get to the setting again?

thanks,
Heike

Accepted answer


permanent link
Ralph Schoon (60.5k33643) | answered May 16 '17, 2:06 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 Heike,


I don't have an idea why the section might be gone (except you maybe are in the wrong application e.g. JTS and not CCM). Inb any case all these property changes away from the default are stored in the server/conf/ccm/teamserver.properties for RTC. Open that file, look for your 1000 entry and delete that line or set some other value. 

Heike Spayne selected this answer as the correct answer

Comments
Heike Spayne commented May 16 '17, 11:12 a.m.

 Thank you - that is indeed what I did - I used the jts advanced properties to look for the parameter, instead of the ccm properties!

One other answer



permanent link
Donald Nong (14.4k314) | answered May 16 '17, 3:21 a.m.

If you cannot access the property from the web UI, you can modify it in the server/conf/ccm/teamserver.properties file. You have two approaches.

1. Modify the file directly and remove this line - it will revert the property back to its default value.
com.ibm.team.workitem.query.fulltext.merge.limit=1000
2. At the top of the file, a comment indicates which backup file is the previous version of the teamserver.properties file. Find the file with the correct configuration (you may need to trace back a few versions) and make it the current teamserver.properties (rename it).

Both methods requires restarting the server to take effect.


Comments
Heike Spayne commented May 16 '17, 11:11 a.m.

 Thank you - that is good advice. Turned out I indeed went to the jts admin page instead of ccm, as the prior post suggested.


Your answer


Register or to post your answer.