It's all about the answers!

Ask a question

Not able to register HP loadrunner adapter due to error "Stored configuration is out of sync. Adapter is re-registering."


Monica Shishodia (1113) | asked Nov 14 '16, 10:58 p.m.
retagged Nov 25 '16, 5:50 a.m. by Minakshi Jaint (5113)
  We have Jazz team server (5.0.2) with RQM 5.0.2. We are trying to integrate HP ALM with RQM and have installed Rational HP loadrunner adapter on our jazz server.
Now when i try to run adapter from client machine, after providing server url, user id, adapter name, project area. But i am getting same error again and again.

"Stored configuration is out of sync. Adapter is re-registering"

Please note i have "Rational Quality Manager - Quality Professional-Token" enabled in client license.
The user i am using while connecting has admin,tester and test lead roles assigned to it. It also has access to project area.
In the Repository Permissions section, JazzUsers is selected.
I can run Command line adapter with same configuration.

I am running out of options to figure out why the error is appearing?
is there a version mismatch?
How can i check the version of installed adapter on server side (through Admin web console)?

Comments
Donald Nong commented Nov 14 '16, 11:17 p.m.

I assume that you have already checked out these posts.
https://jazz.net/forum/questions/120304/why-when-selecting-local-resources-for-pointing-to-command-line-test-scripts-does-it-get-stuck-on-loading
https://jazz.net/forum/questions/141436/rqm-qtp-adapter-integration-stored-configuration-is-out-of-sync-adapter-is-re-registering

If you only see this simple message, you need to somehow enable debug mode to see more verbose messages to understand the issue.


Monica Shishodia commented Nov 14 '16, 11:33 p.m.

  Hi Donald


Thanks for reply.

Few points i have checked :
--I can access RQM server from the machine i am trying to run adapter on.
--The java version is 1.8.
--I have deleted config.properties file and tried to run the adapter but same result.
--The public URL i am using is ,https://almdev.cl.internal.xyz.com/qm.
--Jazz user is selected under repository permissions.
--Enabled token is Quality professional.
--There are only three roles in our project area, Admin, tester, testlead. All are assigned to user i am trying to connect with. This user has the permissions to register and save an adapter.

What i am missing here?


Monica Shishodia commented Nov 15 '16, 12:37 a.m.
Can it be a proxy related issue?

 I have enabled debug too and below is what i am getting in log file.

       - Adapter process going for sleep for: 5 seconds.
       - Adapter polling RQM server for instructions.
   - Stored configuration is out of sync. Adapter is re-registering.



Donald Nong commented Nov 15 '16, 1:32 a.m.

That's interesting. So the adapter can actually be registered but just can't stay "stable". If you have quick hands, maybe you can copy the configuration file for different registrations and see what has been changed? In the case of RQM Command Line Adapter, the configuration file is Config2.ini and it holds the "stored configuration".


Monica Shishodia commented Nov 15 '16, 1:36 a.m. | edited Nov 15 '16, 1:45 a.m.

 I have used same settings (repository, project area, user, polling etc) in command line adapter as well. Its connecting perfectly but not the LoadRunner.

Loadrunner log is :
- Instantiating an adapter instance...
- Adapter Arguments ... 
- -repository
-https://almdev.cl.internal.xyz.com/qm
- -user
- test
- -password
- *
- -adapter
- HP_load
- -projectArea
- TEST_RQM
- Adapter Name
- HP_LoadRunner
- Polling Interval (seconds)
- 5
- Successfully created an HTTP client
- The adapter is now connected
- resolved project area named "TEST_RQM" to alias: TEST_RQM
- Created LoadRunner Adapter 5.0
         - Adapter polling RQM server for instructions.
       - Stored configuration is out of sync. Adapter is re-registering.


Paul Slauenwhite commented Nov 17 '16, 7:15 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Can you confirm if the adapter configuration file is being updated when the adapter re-registers?


Monica Shishodia commented Nov 17 '16, 10:06 p.m.

 Hi Paul


Thanks for reply.
I checked content as well as time stamps on config.properties during adapter registration and re-registration. No change.
Any idea what's happening here?

Regards,
Monica


Don Yang commented Nov 17 '16, 11:26 p.m.

what is your loadrunner version?


Monica Shishodia commented Nov 17 '16, 11:29 p.m.
Hi Don

Loadrunner version is 5.0.2 (the adapter on client machine). Although i am not able to check version on our jazz server as i can only access it through web UI. Our jazz server is 5.0.2 so i am assuming same would be the adapter at server. Is there a way to check it through UI?


Regards,
Monica


Monica Shishodia commented Nov 20 '16, 10:29 p.m.

 I have received input that it might be related to Repository Permissions. Our user has Jazz User enabled but according to input it should be at least one of these, to register adapters,

-JazzAdmin
-JazzProjectAdmin

Is that correct coz i did not come across this in documentation or blogs?


Paul Slauenwhite commented Nov 21 '16, 8:12 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Monica, there was a recent update to the CLA/Selenium adapter readmes related to permissions (see Information missing in the following documentation: Setting up and starting the command-line adapter (154875)).  Also, are you using a proxy?  If so, see The JUnit adapter does not update the Config2.ini configuration file with the proxy credentials. (157284).


Monica Shishodia commented Nov 21 '16, 9:59 p.m. | edited Nov 21 '16, 10:11 p.m.

Hi Paul

Thanks for links. I went through these links. Our user has Register tool adapter permission, XML Export. In XML Import, he can post only (not delete).
But as i said, We are able to register command line adapter. JUnit is also working. Its the HP load runner and QTP adapters which are creating problem.
We are not using proxy.


Paul Slauenwhite commented Nov 22 '16, 6:48 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Thanks Monica for checking.  At this point, I would suggest opening a PMR to investigate.

showing 5 of 13 show 8 more comments

2 answers



permanent link
abhishek gour (3812) | answered Nov 17 '16, 8:53 a.m.
 http://www.ibm.com/support/knowledgecenter/SSYMRC_6.0.3/com.ibm.rqm.adapter.loadrunner.ua/html/topics/LRPrepareArchiveShared.html

The above link explains a bit more about the ZIP archive which contains configuration.properties file. This is just to confirm that there is no issue from this  archive perspective.

Comments
Monica Shishodia commented Nov 17 '16, 9:54 p.m.

 Hi Abhishek


Thanks for reply.

I believe that's for when we are trying to execute 'Use test resources from a shared location'. In my scenario, i am trying 'Use test resources that are local to a test machine'--> Select Adapter.

Any idea why that's creating error?

Regards,
Monica


permanent link
Monica Shishodia (1113) | answered Nov 23 '16, 12:26 a.m.
Thanks All for your valuable inputs and time. I really appreciate taking out time and looking into it. What worked for me was Repository Permissions as JazzAdmin (although one can try JazzProjectAdmin as well).
We can now view the adater as registered in Adapter console of IBM RQM.

Thanks Again!!.

Regards,
Monica

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.