It's all about the answers!

Ask a question

Slow Response from Help


Chris Hardy (3641619) | asked Feb 22 '13, 12:30 a.m.
retagged Feb 22 '13, 10:05 a.m. by Ralph Earle (25738)
Using CLM 4.0.1, DB2 9.7 and WAS 8.0.0.3

Does anyone else notice that the help function is very slow.
I have seen that it takes approx 2 mins to bring up the initial window, and when selecting anything from the contents it takes a minute to update the contents in the main window

has anyone else noticed this and have any experience of how to speed this up?

Comments
Sterling Ferguson-II commented Feb 22 '13, 9:23 a.m.

One answer



permanent link
Guido Schneider (3.3k137699) | answered Feb 22 '13, 3:32 a.m.

If you have not configured to use a local help content, the clmhelp context will use a remote site from IBM. Because this is server based, through the clmhelp application, the server must have access to public Internet. You are not able to configure a proxy server for this, nor you are able to configure username/password for this Internet connection if you have a firewall which needs authentication.

I suggest to disable remote content and install the help content locally.

Disable remote help:
https://clmserver01.yourcompany.com/clmhelp/remote/remotehelp.jsp

Download of Helpcontent:
http://download.boulder.ibm.com/ibmdl/pub/software/rationalsdp/documentation/updatesites/

Local Install of Helpcontent:
https://clmserver01.yourcompany.com/clmhelp/updater/updatewar.jsp

Alternativly you can switch to client based help access and not use the clmhelp application of JTS in Advanced Properties to set in EACH application (JTS, CCM, RM):


com.ibm.team.repository.service.internal.webuiInitializer.ConfigPropertyInitializer

Web help URI: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/index.jsp

BTW: All is described in Infocenter:

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.help.common.rational.remote.web.doc/topics/c_web_del_web.html

Your answer


Register or to post your answer.