It's all about the answers!

Ask a question

OAuth Domain Issue?

Kevin Poindexter (113) | asked Nov 08 '12, 12:45 p.m.
 Hi All. Hope that your day is great. I'm running into one last issue, which is not allowing me to create lifecycle projects. I hope that someone can help!

My issue is:

Application: there is no Oauth domain in the discovery resource at "" for "/rm" that is a prefix of the discovery resource URI.

This could be caused by changing the public URI setting in the application or friend. Oauth domains from the discovery resource: [,]

2 answers

permanent link
Ara Masrof (3.2k15) | answered Nov 08 '12, 2:28 p.m.
Take a quick look at this past forum topic; it may be helpful in this case

permanent link
John Vasta (2.6k15) | answered Nov 12 '12, 8:22 a.m.
 In this case, it appears that your RRC application is not configured correctly, because you have registered it using, but it thinks its URL is I'm not sure how you could have done that, other than by not executing the CLM setup wizard completely, or not noticing errors during its execution. (Or doing something like copying over the RRC configuration files after you have set it up.)

RRC's configuration files are set to use /rdm out of the box, but when it is registered with a JTS using /rm instead, it should update its configuration files to reflect the correct URL.

Kevin Poindexter commented Nov 13 '12, 3:37 p.m. | edited Nov 13 '12, 3:37 p.m.

I currently have it re-registered from the registered applications list.

However, when I go to create a project and use RM I get an error because it somehow is not built right? 
Do I need to reregister it as ? I left the default discovery URI that it discovered on its own.

John Vasta commented Nov 13 '12, 4:28 p.m.

 I don't know what app server you deployed in (Tomcat or WAS), or how you did the install (unzip or Installation Manager), but somehow you have an inconsistency in how the RRC application is deployed vs how it is configured. If it is deployed with the context path /rm (e.g. it is deployed in Tomcat, and the war file name is rm.war), then it will only respond to /rm URLs. But since it is reporting that it thinks it's URL is using /rdm, then I suspect that the server/conf/rm/ file contains such URLs (that's how it ships out-of-the-box). The URLs in that file must match how the application is deployed.

Was this an upgrade from a previous release? If so, the URL cannot be changed - if it was deployed at /rdm before, it must be deployed that way now.

You could make sure that the file is consistent with the way it is deployed, but not knowing the history of how you got into the state you're in, I don't know whether it is deployed correctly or not, or whether there are any other problems besides this inconsistency. Can you describe how you did your installation?

Kevin Poindexter commented Nov 13 '12, 4:34 p.m. | edited Nov 13 '12, 4:38 p.m.
I'm just trying to figure this all out. I unregistered it and tried to register as rdm but that does not work. What exactly do I need to do to get rm working, as I need the rm application?

John Vasta commented Nov 13 '12, 4:38 p.m.

I cannot answer your question without knowing what you've done, and how your CLM applications are deployed.

Kevin Poindexter commented Nov 13 '12, 4:56 p.m. | edited Nov 13 '12, 5:01 p.m.

This was a fresh brand new installation, no upgrade. Fresh install of Win2k8 Server also. I used the IBM installation manager and had the repo files stored locally. I  pointed the IBM install manager to the directory of the files and deployed from there. I'm using TomCat and I'm using SQL and setup Databases for jts, ccm, qm along with Databases for the warehouses. After that, I ran the custom setup and set my public URI which is not an actual URI. I put in all the settings for each application to ensure it made a JDBC connection to the databases. I let the custom install create the DB tables, everything has been successful, including getting passed the RM config. Finally after I finalized the server settings, I went to create a life cycle project for requirements composer and received the errors in my first post. If there is anything additional that you need, please advise. I'm still getting up to speed on this product as it is my first time.

John Vasta commented Nov 13 '12, 5:14 p.m.

 What do you mean by "set my public URI which is not an actual URI"?

I take it you went all the way through the setup wizard, to the very end, going through the setup of each application?

At this point I suggest opening a ticket with IBM support. Someone will probably want you to collect log files and other information from your system, and that doesn't work very well in this forum.

Kevin Poindexter commented Nov 14 '12, 10:32 a.m.

 I mean it is a stand alone server, not on a network but just local laptops and the computer hosting the instance. The public uri I set is an actual .xxx domain suffix, does that have anything to do with it?

And yes, I went all the way through the setup wizard, with each application through the custom setup wizard.

John Vasta commented Nov 14 '12, 11:15 a.m.

 If the hostname you used is resolvable on all the machines in your standalone network, then it shouldn't be a problem.

As I said, you'll need to work with support on troubleshooting what state you got into - that's not really feasible in a discussion forum.

showing 5 of 8 show 3 more comments

Your answer

Register or to post your answer.