It's all about the answers!

Ask a question

JTS is not starting (on Tomcat) - 4.0

Marc Nehme (276157) | asked Jul 19 '12, 12:50 p.m.
edited Jul 19 '12, 1:56 p.m.
Simple installation, JTS 4.0 and all CLM apps on Windows 2008 R2 Enterprise x64, on Tomcat. I try to start the JTS via 'server.startup.bat' and also via Windows icon and the command prompt pops up and then  immediately terminates. I managed to take a screenshot of the command prompt that launches (see below) but it looks normal. There is nothing logged in \server\tomcat\logs.

I've restarted my machine, uninstalled, reinstalled (express), same behavior. Anyone have any ideas or know what is going on?

Karl Weinert commented Jul 19 '12, 1:01 p.m. | edited Jul 19 '12, 1:02 p.m.

Try running server.startup.bat from a command prompt. You should cd to the ..\<rtc-install>\server directory first. This might allow you to see any errors if present.

Marc Nehme commented Jul 19 '12, 1:04 p.m.

Hi Karl,

I've tried that, no luck, same behavior.

Karl Weinert commented Jul 19 '12, 3:05 p.m.

Did it return the list of variables that are set? i.e. Using CATALINA_BASE: Using CATALINA_HOME: etc.. (I can't see your screen shot) If it does try running tomcat\bin\catalina run right afterwards. That should start the server in the same command shell and hopefully return some additional information.

Karl Weinert commented Jul 19 '12, 3:18 p.m.

I just found an easier way to do the same thing. In <rtc install="">\server\tomcat\bin\starup.bat Change "start" to "run" in the following line near the end of the file: "%EXECUTABLE%" start %CMD_LINE_ARGS% to "%EXECUTABLE%" run %CMD_LINE_ARGS%

Bo Chulindra commented Sep 26 '12, 10:47 a.m.

Note that you can check the tomcat logs for errors during startup. The tomcat logs will be in server/tomcat/logs.

Scott Raley commented Oct 28 '12, 8:32 a.m.

I am having a similar problem. I'm trying to install it in Windows 7 and have 4 gigs of memory and it does the same thing as described above. I see the initial catalina parameters set and then the next popup dissapears. I have installed it on XP and it is running fine. Same machine configuration. I have followed a few articles on manually starting the tomcat service with tomcat7w.exe and have tried this but the article does not state how to get the packages deployed for JTS. with the tomcat service started I have tried running the start.bat and server.startup.bat and with the service already started I get a ton of errors in the dos window and then it dissapears. Anyone have suggestions if there is something in Windows 7? I am running it as administrator and running the command prompt as administrator.

showing 5 of 6 show 1 more comments

Accepted answer

permanent link
Marc Nehme (276157) | answered Jul 19 '12, 3:44 p.m.
Ok, I know what the problem was. It was a memory issue. I am running this VM with 2.5 GB RAM, a standard image that I use for other tasks. Clearly, this is not enough for a full CLM 4.0 install. How I caught this was, I kept trying to catch a secondary command prompt that was terminating right after the initial one. This said: "JVMJ9VM015W Initialization error for library j9gc24(5): Failed to allocate default memory space. Could not create the Java virtual machine." I bumped the RAM up to the recommended 4GB and now the JTS has started for me. I should've noticed this earlier. Thanks for your ideas however.
Ralph Schoon selected this answer as the correct answer

Albert Yao commented Oct 28 '12, 1:05 a.m.

My physical memory is only 2 GB, and I have installed the CLM successfully and have no any error, but when I started the JTS, the same problem appeared as your description; how shoud I do to adjust the CLM/Tomcat parameter for the 2 GB memory?

Arne Bister commented Oct 28 '12, 7:43 a.m.

Albert, could you please convert your comment to a question? I think it is more appropriate so that the answer can be separately found when needed. My personal experience is that you will not be able to run full CLM 4.x effectively on just 2 GByte of memory.

- Arne

2 other answers

permanent link
Marc Towersap (481711) | answered Feb 22 '13, 1:31 a.m.
I have the same issue running 64-bit windows 7 professional.  Got exactly the same error, and I have 4 G RAM.

What I did was to edit server.startup.bat using notepad
you'll see a bunch of set JAVA_OPTS
You care about the -Xmx and -Xms options. They are probably set to use 4G (looks like -Xms4G).  You can try setting it to 2G

what the heck are these options?  Check out

I hope this helps!

permanent link
Marc Towersap (481711) | answered Feb 22 '13, 1:34 a.m.
of course, in doing this, your perfomance will suffer if you lower it, but crap performance is better than no performance!  The real solution, install more RAM!

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.