It's all about the answers!

Ask a question

Unable to configure RPE report to work in RTC as a report resource

Marina Hartley (1144) | asked Jan 11 '13, 1:52 p.m.

I have a report template that I generated in RPE that I am trying to deploy in RTC so that people without access to RPE can use it.

I followed the instructions from this page:

and was able to get the template and .dsx file uploaded.  However, I I think I have been unable to properly configure it (as described in

When I try to run the report in RTC it appears to begin generating, but then errors...


Starting run...

Consuming RPE license...

Error in engine No output specified.

Aborting engine execution..."

I'm not sure if the issue is in RPE where I may not have correctly defined the configuration metadata or in RTC, where I may have missed something.


8 answers

permanent link
Kristin Kronstain Brown (176) | answered Jan 11 '13, 2:05 p.m.
Hi Marina,

It sounds like there is some missing configuration information for the output in the document specification (.dsx). Take a look at this section of the Rational Publishing Engine documentation:

It might be that you need to configure an output type, such as Microsoft Word, with an output path, for example.

permanent link
Marina Hartley (1144) | answered Jan 11 '13, 2:16 p.m.
I looked through the information above just in case.  I do have the output set up for Word.  The template generates fine if I publish through RPE.  I tried to add a pdf Output, but it just gave me the same error message.

permanent link
Kristin Kronstain Brown (176) | answered Jan 11 '13, 2:44 p.m.
When you look at the .dsx contents in RPE, are any of the outputs red with asterisks? It might be that RPE generates the report even if there are things that appear unconfigured, but RTC won't generate the report anyway.

permanent link
Marina Hartley (1144) | answered Jan 11 '13, 3:11 p.m.

There were no red asterisks...however, I continued to play with it and I began to wonder how the report could display in RTC if I only had Word or PDF defined as an output.  I added an .html output and re-loaded everything and presto!  It worked! 

Thank you very much for your help!

permanent link
Alanna Zito (1.3k3) | answered Jan 11 '13, 3:13 p.m.
When you run an RPE report in the web UI, it will always run in HTML format. So you are probably seeing the error because you don't have an HTML output in your doc spec.  To generate the report in another format (Word, PDF), you need to run the report, then choose "Export" from the toolbar.

Note that, in many cases, you don't really need to upload the *.dsx to the server in order to run the report - you can use just the *.dta instead.  You can do thing like configure the data source URL and set variable values as parameters of the report in RTC, without needing to upload a *.dsx.

permanent link
Geoffrey Rosenthal (10135) | answered Mar 27 '13, 7:19 p.m.
To Alanna's point, from a re-useability standpoint, if you upload the document specification (.dsx) your Jazz users will only be able to run the report with the previously defined data source queries and document output types as defined in the document specification.  If instead you upload the document template (.dta), your Jazz users could point the template at any number of data sources that would work with the defined template and they would be free to choose the output document type that best meets their needs.

permanent link
Ney 81 (134) | answered Mar 27 '14, 9:15 a.m.
Hi Alanna! I'm very interested to your answer, I need to use my custom report in RTC, but I don't know how to put information about the connection to data source in a .dta, can you help me?. I've a foundation schema and then a dynamic data source for work items. So I think I need to modify just the foundation schema...but how? Can you help me, please?

Alanna Zito commented Mar 27 '14, 3:05 p.m.

Hi Sym,

When you import your custom report into RTC and run it, all the data sources will show up as parameters - you can then set values for the data source URLs.  You do not need to provide user name/password information - the report will run with the credentials of the user who is logged in to RTC.

Also, you should consider converting your comment to a question - that way, more people will see it and be able to help.

Nate Decker commented Mar 12 '15, 2:38 p.m.

I'm hunting through these forums trying to find data about how to do this. I thought I might comment here since this thread seems relevant to my problem.

I have a report which will work when I explicitly specify user credentials as part of the data source configuration. If I leave those credentials blank, the report runs but is unable to fetch data from work items. The data source is being used dynamically.

I read another post that indicated that if I was using a dynamic data source, I needed to use at least one other data source that was not dynamic. Presumably, this enables one data source to provide authentication credentials for the other. I tried that, but it doesn't seem to be working either.

How does this work?

Alanna Zito commented Mar 13 '15, 8:33 a.m.

Hi Nate,

You may want to convert this comment to a question; it will get more visibility than commenting on an old thread.

What version of CLM are you using, and which application are you trying to run your report from?  Generally, when running RPE reports on the server, you don't need to upload the *.dsx.  Is there a reason that you want to use hard-coded user credentials, instead of running the report as whatever user is logged into CLM?  Also, are you getting an error when you run the report, or is it just not returning any data?  If you are getting an error, can you post the full text here?

You're correct that there is some extra configuration needed if your report has dynamic data sources (though, I'm actually not sure if that's the case if you're trying to use hard-coded credentials).  What have you added as the second data source?  When you run the report on the server, what parameters does it have, and what have you entered as values for them?

Nate Decker commented Aug 12 '15, 2:21 p.m.

Alanna, to provide some closure on my participation in this thread, we ended opening a Service Request on this. In our case, the problem was that RTC was configured as a friend of itself. We had read somewhere that this was supposed to be done in certain scenarios. We removed that configuration and it started working.

It was a confusing issue to diagnose, but at least for us that was the solution.

Alanna Zito commented Aug 12 '15, 2:26 p.m.

Thanks for the update Nate, and glad your problem was resolved.  FYI, as of CLM 5.0.1, reports are now tolerant of the case where an application is a friend of itself - so you wouldn't need to remove the friend anymore to get your reports to run.

permanent link
michele choban (1644) | answered Aug 12 '15, 2:16 p.m.


I do not use .dsx files when uploading RQM report to server, but it is not responding to a WORD style sheet that is uploaded.  The word template is a .dot with the filename the same as the report .dta file.  Are there specifics to how this should be done if you are NOT using .dsx files? Report is not responding to styles identified in .dta and .dot file when exported to WORD.

Alanna Zito commented Aug 12 '15, 2:36 p.m.

Hi Michele,

Stylesheets are one case where you will need to upload a *.dsx to the server.  See instructions here (step 7 in particular):

This forum post also contains some additional advice about using stylesheets.

Also, you didn't mention what version of CLM you're using, but support for stylesheets was only added in 4.0.3 - so keep that in mind as well.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.