It's all about the answers!

Ask a question

RQM / RPE Reports - Any reason why a Word Template would be ignored when running through RQM?


William Geck (1034) | asked Jun 08 '15, 3:04 p.m.
I am using RQM 5.0, and have created dta/dsx templates using RPE 1.2.1.  When I run document generation through RPE directly, using a Word Template (with macro), documents are generated perfectly. 

When I upload the dta, and reference documents (dsx and dotm files) as a resource in RQM, then run the report through RQM, the Word template is not used.  Html and Word docs are generated, but the word doc simply does not use the Word template.   I am following the directions in:

https://jazz.net/help-dev/clm/topic/com.ibm.rational.rrdg.usage.doc/topics/t_rrdg_make_reports_avail.html

with all resources relative (no paths) in the dsx file.  Is there a list of common reasons why a document may not generate the same way through RQM as it does in RPE?

I have tried saving the *.dotm file as *.dot, updating the dsx file and using that in RQM, and it still does not use the template.

Accepted answer


permanent link
Alanna Zito (1.3k3) | answered Jun 09 '15, 12:02 p.m.
JAZZ DEVELOPER
edited Jun 09 '15, 2:07 p.m.
When you upload the stylesheet to your report resource in RQM, in the "Files" table, the name should be just filename, without any path - i.e., it should be exactly the same as what you see in the *.dsx (in this case, TestDocument4.dot).  I believe that when you upload a file, it will give it just the file name by default, but if it doesn't, you can edit the name that's there by clicking on it - that will bring up a text box.  Edit the name so that it matches what's in the *.dsx, save the report resource, and run the report again.
William Geck selected this answer as the correct answer

One other answer



permanent link
Ben Sharples (812658) | answered Jun 08 '15, 5:03 p.m.
I had this problem previously.

You have to modify the dsx file manually (I used notepad) and remove any paths from the front of reference to the .dta and .dot files and then attach the .dot and .dsx to the report resource.

Because the .dsx and .dot files are loaded onto the server effectively the path is nill.



Comments
William Geck commented Jun 09 '15, 9:11 a.m.

Thanks for the reply.  In the editor, I made all paths relative.  I have reviewed the XML for the dsx file, and I see no path info.  Is there anything specifically I should look for? 

I have:
<feature tag="Target">
   <property name="path" type="URI" editable="true" visible="true" required="true" value="TestDocument4.doc"/>
   <property name="stylesheet" type="URI" editable="true" visible="true" required="false" value="TestDocument4.dot"/>

And

<feature tag="Template">
  <property name="path" editable="false" visible="true" required="false" value="TestDocument4.dta"/>




Alanna Zito commented Jun 09 '15, 9:38 a.m.
JAZZ DEVELOPER

It looks like everything is OK in your .dsx file.  Here are a couple more things you could check:

-In your report resource, make sure that the name of the uploaded
.dot file is exactly the same as it is in your *.dsx (i.e., it should be "TestDocument4.dot")

-Check the QM log files.  If the server is having trouble finding the stylesheet, you should see a warning message that says something like "Could not find stylesheet <file name>".

-Also, just to be clear, the template will only be used if you export the report in Word format - it won't be applied to the default HTML output.

-


William Geck commented Jun 09 '15, 11:42 a.m.

Thanks.  I will see if I can get access to the logs. 

In RQM, it shows up as:
C:\fakepath\TestDocument4.dta
C:\fakepath\TestDocument4.dot

I had done a test, adding TestDocument4.css as a stylesheet for the HTML output, and the view-source shows it being added, though if you following the link, the css is empty.    I will edit this reply with what I can find.


William Geck commented Jun 09 '15, 1:57 p.m.

Excellent.  Thanks Alanna.  Removing C:\fakepath\ from the .dot file (but not the .dta file) did the trick.   If you could mark your last comment as an "answer" i will mark it as the accepted answer. 

As an aside, I am actually using a .dotm file as the template (the .doc was a test to see if file format was an issue).  It works fine as a .dotm, but the produced file is still a doc, so we loose some formatting - though not critical.  Will research that next. 


Alanna Zito commented Jun 09 '15, 2:11 p.m.
JAZZ DEVELOPER

Done - converted the comment to an answer, and edited it a bit so that it stands alone as an answer.

Re: using .dotm vs .dot - I'm not familiar with *.dotm, so I'm not sure if it's supported on the server.  Does it work properly if you run the report from RPE?


William Geck commented Jun 10 '15, 8:33 a.m. | edited Jun 10 '15, 8:34 a.m.

In RPE, when you use a .dotm stylesheet, and output file name .docm, the file is used correctly.  So .dotm is supported in that respect.  However when running through RQM, the output file format defaults to .doc.  The .docm file is still used ok as a source though.  Our company template is docm, and includes some advance formatting macros.  For now, I am leaving as is.  .docm input stylesheet with .doc output file.  It would be nice to have *.docm output since additional document edits would retain the full doc capability.  If I find any additional information I will update here.

Regarding this specific question:  I think it would be good to update the documentation (link in original question) to mention that any stylesheets (DOT, CSS, etc) should have C:\fakepath stripped from the path after attaching to the resource.  But not from the DSX attachment. 


Alanna Zito commented Jun 10 '15, 9:22 a.m.
JAZZ DEVELOPER

Ah, OK - I understand the .dotm situation now.  You're right - RQM (and RTC) both default to the .doc extension when generating RPE reports for Word.  If you need support for *.docm, you could log an enhancement request.

showing 5 of 7 show 2 more comments

Your answer


Register or to post your answer.