It's all about the answers!

Ask a question

problem with repotools-jts.sh -syncUsers


Sterling Ferguson-II (1.6k7235249) | asked Dec 13 '12, 3:32 p.m.
CLM 4.0.0.1
Red Hat 5.x
Oracle 10g

All,

I logged in as an admin and made some changes in CLM.

There were new users added to LDAP.

I logged in to the Linux box and tried to run repotools-jts.sh -syncUsers:

./repotools-jts.sh -syncUsers repositoryURL=https://address:9443/jts adminUserId=parameter adminPassword=parameter

and I get:

CRJAZ1357E Failed to login into the server 'https://address:9443/jts'. Check the login credentials.

3 answers



permanent link
Ralph Schoon (54.0k13641) | answered Dec 14 '12, 4:42 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I have seen this only in cases where I mistyped the user ID, or the password. Are you sure the account and password provided work? Do other repotools commands have the same issue?

Comments
Sterling Ferguson-II commented Jan 28 '13, 10:09 a.m.

Thanks Ralph for this response...the issue "resolved" itself because of the nightly sync.


Again, this morning though, I made another addition to the LDAP server at this client site and I am getting the same error message. I login 3-4 times a day as a JazzAdmin, so I don't understand why this keeps happening.


Bo Chulindra commented Jan 28 '13, 10:50 a.m. | edited Jan 28 '13, 10:51 a.m.
JAZZ DEVELOPER

The only times I've seen the login failed error is if the credentials are wrong (I believe that the web UI will let you log in with the wrong case credentials, but repotools may not be as forgiving) or the database is in a bad state (for example, if the Jazz tables were not created yet or there is some problem connecting to the database).

I don't think your problem is with the database since the LDAP nightly sync works. Perhaps the case of your login credentials are not matching your LDAP credentials? Also, if there are special characters, you'll want to use quotes (or use the credentialsFile parameter).

Try running repotools -listLicenses with your credentials and see if that works.


Sterling Ferguson-II commented Jan 28 '13, 12:59 p.m.

Same error...I don't understand. Again, I am fine logging in and out with my LDAP user ID and password via Web and RTC client. I am a JazzAdmin. I will submit a PMR via the customer.


permanent link
Guido Schneider (3.3k137499) | answered Jan 28 '13, 1:53 p.m.
We have similar issues because we have multiple LDAP server behind the lDAP server address. They are served by DNS round robin with a DNS TimeToLive of 15 min.

So we don't know exactly which LDAP server is serving the authentication request and which one is used during LDAP synch etc...

We found out, that two of our six LDAP servers were not working correctly, and that gave us such random results.

We found out with:
> nslookup ldap.company.net
This showed 6 servers

We tested with a
> ipconfig /flushdns
to get a new IP address of another LDAP server.

As a workaround we have a small scheduled job, which tries to logon and if it fails it does an "ipconfig /flushdns" and writes into a logfiles which IP address was not working. (So we have a statistic, we can show our IT provider.). This job runs evry two minutes in our environment. This can alo be used as an Heartbeat of Jazz and send an e-mail to a sysadmin if it is not working for two/three times.

BTW: we switch off case-sensitivity in all advanced settings of all CLM applications. In Active Directory LDAP this is always case-insensitive and in WAS it's the default.

Comments
Sterling Ferguson-II commented Jan 29 '13, 9:37 a.m.

Thanks for the answer.


We are only using one LDAP server. Again, the tool recognizes me as an admin and I can configure everything, just repotools does not allow it. Unfortunately, last night's sync did not work either.

Frustrating.


Sterling Ferguson-II commented Jan 29 '13, 10:55 a.m.

OK,


It may be a weird LDAP Group setting. The "websphere admin account" can run this tool fine. All of the other "JazzAdmins" can not....


permanent link
Ravikanth Chavali (25424) | answered Jan 11 '15, 8:47 p.m.
edited Jan 11 '15, 9:09 p.m.
 I was able to run it successfully with WASAdmin;

./repotools-jts.sh -syncUsers repositoryURL=https://jts.ravi.org:9443/jts adminUserId=xxxadmin adminPassword=xxxx

Comments
Suresh Raman commented Aug 09 '17, 5:15 p.m.

Should the wasadmin part of JazzAdmin group?


Donald Nong commented Aug 09 '17, 10:34 p.m.

I believe you have to use a user account that has the JazzAdmins role.

Your answer


Register or to post your answer.