It's all about the answers!

Ask a question

When attempting to modify test script in RQM, getting "Failed to find delta predecessor" error


Richard Herrin (212713) | asked Dec 13 '12, 9:54 a.m.

I have users attempting to update test scripts that are getting this error and then a UUID is referenced.  We can't replicate the behavior locally.  This has happened previously, and the next day when we tried to get more detail, the error did not occur for them. 

I have searched the Forum and found references to the upgrade from RQM 2.0.0.2 to RQM 3.0.  We are currently running RQM 3.0.1.2.  We updated over one year ago, so we don't have the ability to migrate again.  Also, we are planning to upgrade to RQM 4.0.1 soon but would like to understand why this error is occurring and how to resolve it.

Accepted answer


permanent link
James Paulus (20411324) | answered Dec 13 '12, 9:58 a.m.
We were seeing this problem with some users when trying to add subscribers to defects.    Found out that the users were using Firefox 16 and that was the problem.
Richard Herrin selected this answer as the correct answer

Comments
Richard Herrin commented Dec 13 '12, 10:29 a.m.

They were using FF - which has proven more performant, but when they went to IE it worked as expected.  Thanks for the amazingly quick answer!!


James Paulus commented Dec 13 '12, 10:31 a.m.

E-mail alert :)


Susan Lafera commented Dec 13 '12, 1:23 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Is this the error message number? 

CRJAZ1034I

We are building the error message content here:

https://jazz.net/help-dev/CLMErrorMessages/index.jsp

One other answer



permanent link
Ara Masrof (3.1k15) | answered Dec 13 '12, 10:22 a.m.
JAZZ DEVELOPER
 If this is specific to certain Test Scripts, there may be an issue with the underlying xml within the Test Script itself.
You can obtain the Test Script feed via the RQM rest API; this is something the RQM support could help out with as well.
If there is an issue with the XML it can be modified and “PUT” back (using Poster or the RQM url utility).
Also, as noted by James, be sure you are accessing RQM with a supported browser version


Comments
Richard Herrin commented Dec 13 '12, 10:30 a.m.

Looks like the browser change solved the problem.  Thanks.

Your answer


Register or to post your answer.