It's all about the answers!

Ask a question

Why RTC client on 2.0.0.2 ifix 8 is not compatible with RTC server on 2.0.0.2 ifix 6?


Stefano Antoniazzi (170711) | asked Jun 27 '12, 5:03 a.m.
Actually we're running RTC server on version 2.0.0.2 iFix6. The 2.0.0.2 iFix6 client doesn't install on  Rational Software Architect 8.0 64 bit but we found a solution in  https://jazz.net/downloads/rational-team-concert/releases/2.0.0.2iFix8?p=releaseNotes

We installed the client upgrade using the IM repository for 2.0.0.2 iFix 8 variation of the RTC Eclipse Client, but we get this message when connecting to the server:

"Client and server versions do not match.
Client version: 2.0.0.2 iFix7
Server version: 2.0.0.2 iFix4"

I know that the first ifix7 had compatibility problems and that's the reason for which I've seen soon an ifix7a version...
The message really sounds strange and unexpected or am I missing something?







Comments
Stefano Antoniazzi commented Sep 17 '12, 5:36 a.m. | edited Sep 18 '12, 1:38 a.m.

 In another thread we found this:



"You can use a client whose fourth digit is greater than that of the server, i.e. a 3.0.1.2 client can talk to a 3.0.1 server, but the other digits of the client cannot be greater than the corresponding digit of the server. "

Is it an official answer?

Accepted answer


permanent link
Geoffrey Clemm (30.1k23035) | answered Sep 18 '12, 1:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
That is my understanding of the standard compatibility rules.

And in any case, that error message doesn't make sense to me either, since you have installed the ifix8 version of the client (not the ifix7 version).  I'd suggest filing a defect work item on jazz.net for this issue, and see how the development team responds (and report back to us here).
Stefano Antoniazzi selected this answer as the correct answer

One other answer



Your answer


Register or to post your answer.