It's all about the answers!

Ask a question

Error cluster RTC


Angelo Corna (25938270) | asked Feb 18 '18, 10:12 a.m.
retagged Mar 13 '18, 11:10 a.m. by Ken Tessier (84117)

I've implemented a cluster following the instructions of RTC 6.0.5 installation guide.

Unfortunately, when I try to connect to CCM, I receive the following error

2018-02-18 16:11:54,681 [Default Executor-thread-151 @@ 16:11 <unauthenticated> <Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6@192.168.1.51> /ccm/web]  WARN .distributed.internal.members.ClusterMemberService  - CRJAZ2416W Failed to read the node ID of the current cluster. If you can see full list of members in web admin cluster page UI, you can ignore this warning. Otherwise, look at the associated stacktrace and resolve the error that is reported.

com.ibm.team.jfs.app.distributed.DistributedOperationException: com.ibm.team.repository.common.transport.internal.registry.ServiceNotFoundException: The service 'com.ibm.team.repository.service.internal.distributed.DistributedRestClientService@9ab2090a' failed to find the required service 'interface com.ibm.team.jfs.app.config.IConfigurationPropertiesService'.  Check <prerequisites> in plugin.xml.


Where is the web admin cluster page UI?

Please, can you help me in order to resolve this issue?

Thanks in advance.


Bye.



Accepted answer


permanent link
Ralph Schoon (59.7k23643) | answered Feb 21 '18, 2:46 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please contact support.

The cluster admin page is the ccm/admin page. If a cluster is active you should see a menu entry cluster nodes.

You have an issue with the Distributed Cache Microservice (DCM).

Angelo Corna selected this answer as the correct answer

Comments
Angelo Corna commented Mar 04 '18, 9:52 a.m. | edited Mar 04 '18, 9:52 a.m.

Ralph,

thank you very much for your suggestion. On my team server.property files the parameter com.ibm.team.repository.distributedRestClient.cacheURL was not correctly setted.
Now the custer is up and running.

Bye.


Ralph Schoon commented Mar 05 '18, 3:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Great to hear it is now working. Thanks.

2 other answers




permanent link
vowner owner (25117) | answered Feb 28 '18, 11:35 p.m.

Hi Angelo,

We are also in the process of implementing CCM cluster in clm 6.0.5  by using liberty profiles. Could you please help us here with the steps you performed for the same.


Comments
1
Angelo Corna commented Mar 04 '18, 9:53 a.m.

I've followed the interactive installation guide instructions.

The only problem encountered is reported on this post.

Bye.

Your answer


Register or to post your answer.