It's all about the answers!

Ask a question

"Show View -> Pending Changes" Kills RTC 4.0.4 Client


Gary Mullen-Schultz (28725436) | asked Sep 10 '13, 2:05 p.m.
retagged Sep 16 '13, 8:23 a.m. by Ralph Earle (25738)
I just installed the RTC 4.0.4 Client for Eclipse 4.2.x IDE.  It starts up fine.

However, if I go to the Pending Changes view, Eclipse goes away.  I don't even need to connect to an RTC server for this to happen; going to that view right after starting up a virgin install causes the client to blow up.

Error as below:


Comments
Gary Mullen-Schultz commented Sep 10 '13, 2:06 p.m. | edited Sep 10 '13, 2:21 p.m.


Gary Mullen-Schultz commented Sep 10 '13, 2:20 p.m. | edited Sep 10 '13, 2:21 p.m.

Does not happen with the Eclipse 3.6.x-based 4.0.4 client.


Matt Lennon commented Sep 10 '13, 4:25 p.m. | edited Sep 11 '13, 2:59 p.m.
JAZZ DEVELOPER

 Hi Gary.


Are there any interesting exceptions in the Eclipse .log file? Any javacores?

Did you customize the eclipse.ini file? If so, does it work with the original version?

Are you running any other plug-ins? RSA, RAD, etc? If so, does it run without those?

What version of Windows are you running?

-Matt


Gary Mullen-Schultz commented Sep 10 '13, 5:36 p.m.

Matt:

Thanks for replying.

1. Yes, there are snap, core and javacore* files created.  No Eclipse log file that I can find in "workspace/.metadata."

2. No, it's the original eclipse.ini.

3. Virgin RTC 4.0.4 install.

4. Windows 7 Professional, Service Pack 1.

Gary


Matt Lennon commented Sep 11 '13, 8:25 a.m. | edited Sep 11 '13, 3:00 p.m.
JAZZ DEVELOPER

Hi Gary.


I don't have that problem with my RTC 4.0.4 installation.

Can you send me the snap, core, and javacore* files? Just zip them up and email them to me - I'm in Blue Pages.

   -Matt


Gary Mullen-Schultz commented Sep 11 '13, 8:31 a.m.

Done.  Thanks for your help.

Gary

showing 5 of 6 show 1 more comments

Accepted answer


permanent link
Matt Lennon (61225) | answered Sep 11 '13, 11:13 a.m.
JAZZ DEVELOPER
Hi Gary.

Glad to hear your Eclipse is no longer crashing after you commented out this JVM option in the eclipse.ini file:
-Xshareclasses:name=IBMSDP_%u
I believe this JVM option improves performance by allowing multiple Java-based applications to share compiled classes. In your case, there was something already in this class cache - an old class from an earlier JVM maybe - that caused Eclipse to die with a GPF. I imagine just deleting class cache directory would have also fixed the problem. On my Windows 7 box, it lives here:
C:\Users\<user>\AppData\Local\javasharedresources\

Here is more info on class sharing and the class cache:

-Matt
Gary Mullen-Schultz selected this answer as the correct answer

Comments
Gary Mullen-Schultz commented Sep 11 '13, 1:35 p.m.

Thanks for your help!

One other answer



permanent link
Karl Weinert (2.0k42636) | answered Sep 11 '13, 8:07 a.m.
JAZZ DEVELOPER
The first line is the important part of the error
JVM terminated. Exit code=8096
I found a few hits searching google for that error

One of the more common fixes was to clear the Microsoft Temp directory.
C:\Users\<username>\AppData\Local\Temp

I found some interesting information on clearing the cache using Java commands here:
http://stackoverflow.com/questions/2143155/installation-of-ibm-rad-7-5-fails-with-jvm-crash

Here are a couple technotes that might help.
http://www-01.ibm.com/support/docview.wss?uid=swg21303648
http://www-01.ibm.com/support/docview.wss?uid=swg21627887

Another thing to try is to create a new workspace and see if you have the same problem



Comments
Gary Mullen-Schultz commented Sep 11 '13, 8:30 a.m.

Karl:

Thanks.  I of course scoured Google before posting this and saw that stuff, none of it seemed to help.  Nor a new workspace.

Gary

Your answer


Register or to post your answer.