It's all about the answers!

Ask a question

How do you troubleshoot errors with the Export PDF button on the RQM Test Plan screen?


Janet Charbonneau (831031) | asked Jul 09 '15, 9:36 a.m.
In RQM, when you open a Test Plan, there is an "Export PDF" button.  I am getting errors when I run all of the different options.  When I select Summary, I just get a red "x" and no output.  When I select Comprehensive or Details, I get a partial error.  It will output the Test Case, Test Script and TCER info, but will not output any of the Test Plan info.  Is there any way to troubleshoot this error to see what the problem is?

One answer



permanent link
Don Yang (7.1k2188121) | answered Jul 09 '15, 7:38 p.m.
1) what is RQM version? There is one known defect and you can see if it is something you are having:
https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=138405

2) only one specific TestPlan sees this problem or not?
3) whether test case and other artifacts see this problem or not?
4) if any other browser has the same issue or not?
5) qm.log could be most useful log and if WAS is used, you may also check with systemout.log and see if you can find anything at the time you exported.

In many cases, you may want to contact client support for the thorough investigation.
if it is reproducible for all test plans, you may export the process template for the support to test with: http://www-01.ibm.com/support/docview.wss?uid=swg21641121

I hope these help you to start with.

Comments
Janet Charbonneau commented Jul 14 '15, 11:45 a.m.

Don,

Thanks for the response.  We are on version 5.0.2.  I had tried this export with multiple test plans in multiple projects, but they were all test plans from my test team.  I was successful in exporting a test plan that I created previously.  I am thinking it may be a similar problem to the defect you mentioned.  They have copied and pasted their content from Microsoft Word. While I haven't seen the headers with multiple IDs in any of it, I am wondering if there is "behind the scenes" stuff from Word that is causing my errors??


Don Yang commented Jul 14 '15, 9:54 p.m. | edited Jul 14 '15, 9:54 p.m.

You may check with the sample project area JKE Banking and see if there is any problem in exporting the sample test plan, this can tell if it is fundamental problem in the tool or it is actually project related. From your description, it is likely you are hitting that defect.
I am not sure how you check with the headers in test plan. You can use a REST client(like Poster) to get the XML of a specific test plan(this one should have problem in PDF export):
https://server:port/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/project-area-alis/testplan/urn:com.ibm.rqm:testplan:27

(server:port should be replaced with your public URI, project-area-alias is your QM project area alias, 27 should be the test plan real id in your case), and then examine the header id there.
If yes, you can manually change one id and then use PUT command to update the test plan which would help to PDF export.

The defect description has the explanation on why that problem occurs.

If the user has the original WORD file, they can save it as HTML and open with notepad for its source code and then check if there is any duplicate IDs, if yes, manually change it and then open in a browser and copy the contents again, this is tedious work and similar to the REST API way, it takes some efforts to fix those problem if an upgrade is not possible.

If you can contact client support, you can confirm with them if the fix can be backported into ifix of v5,0,2 so that you can install ifix to resolve the issue.

Your answer


Register or to post your answer.