It's all about the answers!

Ask a question

RQMExecutionTool - Problem with colons (:) in the content of execution variables


Leandro David (721719) | asked Aug 08 '13, 1:15 p.m.
If you are running RQMExecutionTool 4.02 or older you may face the following problem:

If you are using the -variables parameter to pass some execution variable values to your test execution and you have colons (:) as part of those values, the variables will not be received correctly from RQM

Example - f you are running this command:

RQMExecutionTool.jar -tcerId=9999 ...  -variables="test.url:http://myserver:9999/service'"

The execution variable test.url will not be correctly created by RQM. That happens because the  name/value separator is the colon (:) mark and that is somehow confused by the colons at http:  and myserver:

SOLUTION FOR THAT

1 - Ideal:  Use RQM 4.03 or above

1) Make sure both RQM server and RQM Execution Tool are running on version 4.0.3 and above

2) The variables parameter must be set as -variables="test.url:'http://myserver:9999/service'", just add single quote for string with colons. For example, -variables="test.url:'http://myserver:9999/service'"

2 - Ugly workaround - Replace collon by its unicode representation \u003A

if for any reason you can't use version 4.03 or above
The code \u003A is the java unicode that represents the colon character. If you replace the colon by that vlue in the commando line, that will work.
In other words, replace

-variables="test.url:http://myserver:9999/service"
with
-variables="test.url:http\u003A//myserver\u003A9999/service"

Again, that is really ugly but may help in a desperate moment or while your RQM server is not updated to 4.03.

I hope it helps.

Accepted answer


permanent link
William B Chen (3125) | answered Aug 09 '13, 12:11 p.m.
Thanks Leandro for sharing the solution while we are waiting for technote 1646373 to be published on IBM.COM. Many thanks!
Leandro David selected this answer as the correct answer

Your answer


Register or to post your answer.