CRJAZ1791E, "Unknown page format" in "repotools-ccm.sh -addTables"
Hello!
I have got some problems upgrading CCM from v4.0.7 to v5.0.2. The problem occured when executing step:
repotools-ccm.sh -addTables
Log:
2015-04-19 13:49:04,260 Status: 1,100 of 1,160 processed (94% complete). Estimated completion time: 4/19/15 1:49 PM.
2015-04-19 13:49:04,492 Status: 1,160 of 1,160 processed (100% complete). Estimated completion time: 4/19/15 1:49 PM.
2015-04-19 13:49:04,519 CRJAZ2691I No more items to process.
2015-04-19 13:49:04,571 CRJAZ2739I No state migration failures occurred during online migration.
2015-04-19 13:49:04,572 CRJAZ2687I Online migration finished.
2015-04-19 13:49:04,573 CRJAZ2696I Starting post-online-migration tasks.
2015-04-19 13:49:04,573 CRJAZ2684I Cleaning table ITEM_STATES.
2015-04-19 13:49:11,878 The user "ADMIN" has logged out of the database "/home/admin/IBM/JazzTeamServer/server/conf/ccm/derby/repositoryDB".
2015-04-19 13:49:11,878 Unknown page format at page Page(11441,Container(0, 6912)), page dump follows: Hex dump:
00000000: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00000010: 0000 0000 0000 0000 0000 0000 0000 0000 ................
...
00007fe0: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00007ff0: 0000 0000 0000 0000 0000 0000 0000 0000 ................
at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
at org.apache.derby.impl.store.raw.data.CachedPage.changeInstanceTo(Unknown Source)
at org.apache.derby.impl.store.raw.data.CachedPage.setIdentity(Unknown Source)
at org.apache.derby.impl.services.cache.ConcurrentCache.find(Unknown Source)
at org.apache.derby.impl.store.raw.data.FileContainer.getUserPage(Unknown Source)
The script can not be completed because the errors are found. As far I can see from the log, the problem occurs when cleaning ITEM_STATES table. I tried reproduce this situation directly in the Derby database with Squirrel SQL Client, and I have caught the same error (squirrel_error_cleaning_itemstates.jpg).
It must be mentioned that a similar operation when cleaning the table ITEM.TYPES was successful at all. Based on it, I can conclude that the problem is rather in a single table ITEM_STATES.
May be the problem is in big volume of data in ITEM_STATES? For example, I executed:
select count(*) from "REPOSITORY"."ITEM_STATES"
and response was:
127411
Is it permitted for Derby database under control of Jazz CLM?
I will appreciate for any advices which could help me successfully complete the upgrading procedure! Thank you very much in advance!
I have got some problems upgrading CCM from v4.0.7 to v5.0.2. The problem occured when executing step:
repotools-ccm.sh -addTables
Log:
2015-04-19 13:49:04,260 Status: 1,100 of 1,160 processed (94% complete). Estimated completion time: 4/19/15 1:49 PM.
2015-04-19 13:49:04,492 Status: 1,160 of 1,160 processed (100% complete). Estimated completion time: 4/19/15 1:49 PM.
2015-04-19 13:49:04,519 CRJAZ2691I No more items to process.
2015-04-19 13:49:04,571 CRJAZ2739I No state migration failures occurred during online migration.
2015-04-19 13:49:04,572 CRJAZ2687I Online migration finished.
2015-04-19 13:49:04,573 CRJAZ2696I Starting post-online-migration tasks.
2015-04-19 13:49:04,573 CRJAZ2684I Cleaning table ITEM_STATES.
2015-04-19 13:49:11,878 The user "ADMIN" has logged out of the database "/home/admin/IBM/JazzTeamServer/server/conf/ccm/derby/repositoryDB".
2015-04-19 13:49:11,878 Unknown page format at page Page(11441,Container(0, 6912)), page dump follows: Hex dump:
00000000: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00000010: 0000 0000 0000 0000 0000 0000 0000 0000 ................
...
00007fe0: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00007ff0: 0000 0000 0000 0000 0000 0000 0000 0000 ................
at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
at org.apache.derby.impl.store.raw.data.CachedPage.changeInstanceTo(Unknown Source)
at org.apache.derby.impl.store.raw.data.CachedPage.setIdentity(Unknown Source)
at org.apache.derby.impl.services.cache.ConcurrentCache.find(Unknown Source)
at org.apache.derby.impl.store.raw.data.FileContainer.getUserPage(Unknown Source)
The script can not be completed because the errors are found. As far I can see from the log, the problem occurs when cleaning ITEM_STATES table. I tried reproduce this situation directly in the Derby database with Squirrel SQL Client, and I have caught the same error (squirrel_error_cleaning_itemstates.jpg).
It must be mentioned that a similar operation when cleaning the table ITEM.TYPES was successful at all. Based on it, I can conclude that the problem is rather in a single table ITEM_STATES.
May be the problem is in big volume of data in ITEM_STATES? For example, I executed:
select count(*) from "REPOSITORY"."ITEM_STATES"
and response was:
127411
Is it permitted for Derby database under control of Jazz CLM?
I will appreciate for any advices which could help me successfully complete the upgrading procedure! Thank you very much in advance!
One answer
Reading similar cases in the past, this "unknown page format" error indicates that your database is corrupted. The only reliable way to recover is restore from a backup. I do hope that you have a backup of the Derby database.
It is not a production environment, is it? Derby is supported "for evaluation purpose only".