It's all about the answers!

Ask a question

Manually synchronize Stale Data?


Adam Wereszczynski (92811232) | asked May 27 '13, 9:19 a.m.
retagged Aug 12 '13, 11:09 a.m. by Ralph Earle (25739)
Hello,

We are facing intermittent problems with saving Work Items in the Eclipse Client.

In the Team Advisor view, there is "Stale Data" error with error code CRJAZ6055E "The operation cannot be run because the repository contains a newer version of the item it tried to modify. Refresh from the repository and try the operation again.[...]"

Sometimes there is "Data changed remotely" error instead with CRJAZ0223I error code "The following item has been changed by another operation".

However, after a while problem disappears and we suspect that there is a background task that synchronizes Stale Data. Is there a repotools command or another measure to force such synchronization when Stale Data problems start to occur?

Accepted answer


permanent link
Indradri Basu (1.8k1514) | answered May 27 '13, 11:06 a.m.
To me it seems that a WI is throwing this error during a save operation when the system figures out that something has changed in the WI since you opened it. If the user refreshes (an icon on the top right corner) the WI and then save, it should allow you to.
As per my understanding, there is nothing stored as stale data for any task to process and this is more of a validation.
Adam Wereszczynski selected this answer as the correct answer

Comments
Adam Wereszczynski commented Jun 04 '13, 7:32 a.m.

In our environment we were seeing Stale Data for over two hours until finally it went away. That is why I suspected that there was some synchronization service that is run periodically.

3 other answers



permanent link
praveen patidar (8612644) | answered Aug 06 '13, 11:46 p.m.
we are getting the same issue but with only selected work items. The work items are not getting refreshed with the Repository. 

Is there any task that can be run for synchronize data from repository. Client is stuck as he cannot update the work item?

Some time it shows the like : CRJAZ6055E The operation cannot be run because the repository contains a newer version of the item it tried to modify. Refresh from the repository and try the operation again. For more details, open the help system and search for CRJAZ6055E.

some time option for merge changes, some time the log for current and target state of the work item. 

Comments
sam detweiler commented Apr 04 '14, 2:42 p.m.

anyone ever see any pattern here?


we have an epic which I just opened ( I closed my eclipse and started fresh)
I added a space to the summary (get save button active), press save .. boom

I look at the current/before details and don't see anything wrong.   last changed at 10:47 am this morning, attempting save at 14:37 this afternoon.  

we have a couple pre-condition plugins installed (which I wrote), but they do not save

the user has made a clone of the epic, and the new one works fine. 


sam detweiler commented Apr 07 '14, 8:11 a.m.

now 2 days later the same workitem still exhibits the same problem. so if it is cache, nothing cleared it. 


My system was rebooted to move buildings.
we will restart CCM tonight.

if anyone has any other suggestions..


permanent link
Joerg Aust (612) | answered May 10 '14, 1:41 a.m.
edited May 10 '14, 1:44 a.m.
in the last 1,5 years it happens two times in our environment.
only the reboot of the RTC application server fixed the issue.
CRJAZ0223I

permanent link
Juan Pablo Bruno (26410) | answered Oct 15 '15, 2:31 p.m.
@Indradi Basu I tried the refresh thing and it didn't work. The only workaround we found so far is to reboot the application server. We didn't have a lot of these issues, but probably 4 or 5 in the past year.

Your answer


Register or to post your answer.