It's all about the answers!

Ask a question

WAS install issue on 4.0.4 with RRDI


Daniel W (13710) | asked Oct 25 '13, 9:48 a.m.
edited Nov 04 '13, 6:28 p.m. by Stephanie Taylor (24115)
Initially, I thought I installed the WAS 8.5.0 correctly using IM. But the problem I discovered during RRDI setup.
RRDI is unable to recognized the app server. Then I found out there is a bug on WAS 8.5.0. Then I tried to install the latest fix. It prompted to install 8.5.5 as the latest fix. But I needed only 8.5.0.2.  I had tried both, both got this following error.

###ERROR 1###
The following errors were generated while updating.

  CRIMC1029E: Adding zip com.ibm.websphere.BASE.baseonly_004_windows.all 8.5.2.201303272316 to repository C:\Program Files (x86)\ibm\IMShared failed.

    CRIMC1085E: Resumable download failed for: E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.BASE.baseonly_004_windows.all_8.5.2.201303272316.zip.

      'zip com.ibm.websphere.BASE.baseonly_004_windows.all 8.5.2.201303272316' does not exist (at E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.BASE.baseonly_004_windows.all_8.5.2.201303272316.zip).

      java.io.FileNotFoundException: E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.BASE.baseonly_004_windows.all_8.5.2.201303272316.zip (The system cannot find the file specified.)

      Elapsed time 00:00.00.



###ERROR 2(same)###

Update failed.

  CRIMC1029E: Adding zip com.ibm.websphere.LIBERTY.baseonly_003_windows.all 8.5.2.201303272316 to repository C:\Program Files (x86)\ibm\IMShared failed.

    CRIMC1085E: Resumable download failed for: E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.LIBERTY.baseonly_003_windows.all_8.5.2.201303272316.zip.

      'zip com.ibm.websphere.LIBERTY.baseonly_003_windows.all 8.5.2.201303272316' does not exist (at E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.LIBERTY.baseonly_003_windows.all_8.5.2.201303272316.zip).

      java.io.FileNotFoundException: E:\Cognos\Files\WAS\WAS8.5_FP002.1\native\com.ibm.websphere.LIBERTY.baseonly_003_windows.all_8.5.2.201303272316.zip (The system cannot find the file specified.)

      Elapsed time 00:00.00.


2 questions I want to ask is that.
1, What do I need to do to fix this error?

2, Is there any bug free version of WAS that requires no fix?

Our environment is windows 2008 R2 enterprise 64 bit, with 1.6.0_30 already in place.
                                          

4 answers



permanent link
Rosa Naranjo (2.8k11420) | answered Oct 25 '13, 1:46 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hello
I am not sure what was the origin of the WAS install package.  In the past, when I have had to install WAS 7 or WAS 8 for CLM or RRDI, I start with the base package and apply the fixpack to the various parts of WAS such as the base and the JDK. 

This sounds like a question for WAS support.  However, I found this technote for you:  http://www-01.ibm.com/support/docview.wss?uid=swg24034672
Find the part of this technote that applies to what you are trying to do.
In order to meet the CLM System Requirements for 4.0.4, you should be trying to install 8.5.0.2. 

I suggest you go back to how you started with having installed WAS 8.5 and then follow the technote to install FP 02 (8.5.0.2) for WAS.  Then proceed with the RRDI setup.

Comments
Daniel W commented Oct 25 '13, 2:19 p.m.

Rosa,
That's exactly what I was trying to do.
There is an option in IM to select the recommendation.
And the recommendation is 8.5.5
But If i uncheck that option, I can see 8.5.0.2.

However, I have tried the 8.5.0.2 Fix pack 00002.
That's when I got the error in my original post.


Rosa Naranjo commented Oct 25 '13, 4:12 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Ok. If you have already retried using a local IM repository of the FP 02, I recommend calling WAS support. 


permanent link
Daniel W (13710) | answered Oct 28 '13, 10:27 a.m.
Is there any other version of WAS that is compatible with RRDI that may not require complicated fix pack?
Or just simple fix pack.
What I want to do is try to avoid going through WAS support, since it is not my focus.

My environment is windows 2008 R2 enterprise 64 bit, with existing JRE 1.6.0_30.



permanent link
Rosa Naranjo (2.8k11420) | answered Oct 28 '13, 10:42 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Looking at this page https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements403#A5_Application_Servers
I see you have a few more options.  How about what is bundled with CLM? WAS 8.0.0.3? I will also copy this note from this page:  WAS and DB2 bundles are only available on Passport Advantage and in the CLM Media (not on Jazz.net). Customers upgrading from CLM 3.0.1 and 4.0 are entitled to continue using WAS 7.0.x and WAS 8.0.x as long as CLM supports those versions.
Do you have access to Passport Advantage? Perhaps what is available is a download of a self-contained WAS 8.0.0.3 which does not require installing 8.0 and then applying the fixpack.

permanent link
Karl Weinert (2.0k42536) | answered Nov 05 '13, 8:59 a.m.
JAZZ DEVELOPER
Have you tried again? I'm wondering if it was just some sort of network issue.

You can also try downloading the patches and installing locally
You can find the patches here
You will probably want the two zip files listed next to:
"Application Server V8.5.0.2 local repository ZIP Files containing Base, Express, Developers, ND, NDDMZ, Java SDK"

Unzip them both into the same directory.
Add a local repository in IM and point it to the top level repository.config file.
You may be prompted to log into the download site. If you are press cancel until it stops prompting.
You should now see the available updates from the local repository.





Your answer


Register or to post your answer.