It's all about the answers!

Ask a question

Installing RTC client using Installation Manager on top of Eclipse Kepler 4.3 causes errors


israel barroso (815) | asked Mar 27 '14, 9:53 a.m.
edited Mar 31 '14, 2:38 a.m. by Krzysztof Kaźmierczyk (7.2k34387)
Hi, Does somebody install the client for eclipse 4.2.x under RTC 4.0.6 in Kepler 4.3.x?. I´m using IBM Installation Manager v1.7 and I´ve got this error  and i haven´t idea what is happening:

No se puede completar la instalación debido a una dependencia en conflicto.
  Software que se está instalando: IBM Rational Team Concert Client_1 2014.3.27.144134 (IBM Rational Team Concert Client_1 com.ibm.sdp.eclipse.ide 2014.3.27.144134)
  Software instalado actualmente: Eclipse IDE for Java EE Developers 2.0.2.20140224-0000 (epp.package.jee 2.0.2.20140224-0000)
  Sólo se puede instalar uno de los siguientes a la vez:
    ECF Core Identity API 3.2.0.v20130604-1622 (org.eclipse.ecf.identity 3.2.0.v20130604-1622)
    ECF Core Identity API 3.1.200.v20120610-1946 (org.eclipse.ecf.identity 3.1.200.v20120610-1946)
  No se puede satisfacer la dependencia:
    De: IBM Rational Team Concert Client_1 2014.3.27.144134 (IBM Rational Team Concert Client_1 com.ibm.sdp.eclipse.ide 2014.3.27.144134)
    A: org.eclipse.equinox.p2.core.feature.nls1.feature.group [1.1.0.v201305100939,2.0.0)
  No se puede satisfacer la dependencia:
    De: Eclipse IDE for Java EE Developers 2.0.2.20140224-0000 (epp.package.jee 2.0.2.20140224-0000)

    A: org.eclipse.platform.ide 0.0.0
  No se puede satisfacer la dependencia:
    De: org.eclipse.ecf.identity NLS Support 3.1.200.v201305100939 (org.eclipse.ecf.identity.nl1 3.1.200.v201305100939)

    A: bundle org.eclipse.ecf.identity [3.1.0,3.2.0)
  No se puede satisfacer la dependencia:
    De: Equinox p2 Core Function 1.2.1.v20140221-1852 (org.eclipse.equinox.p2.core.feature.feature.group 1.2.1.v20140221-1852)
    A: org.eclipse.ecf.identity [3.2.0.v20130604-1622]
  No se puede satisfacer la dependencia:
    De: Equinox p2 Core Function Translations 1.1.0.v201305100939 (org.eclipse.equinox.p2.core.feature.nls1.feature.group 1.1.0.v201305100939)

    A: org.eclipse.ecf.identity.nl1 [3.1.200.v201305100939]
  No se puede satisfacer la dependencia:

    De: Equinox p2 Provisioning for IDEs. 2.2.0.v20140221-1852 (org.eclipse.equinox.p2.user.ui.feature.group 2.2.0.v20140221-1852)

    A: org.eclipse.equinox.p2.core.feature.feature.group [1.2.1.v20140221-1852]

  No se puede satisfacer la dependencia:
    De: Eclipse Platform 4.3.2.M20140221-1700 (org.eclipse.platform.ide 4.3.2.M20140221-1700)

    A: org.eclipse.equinox.p2.user.ui.feature.group [2.2.0.v20140221-1852]

Accepted answer


permanent link
Krzysztof Kaźmierczyk (7.2k34387) | answered Mar 27 '14, 12:57 p.m.
Hi Israel,
It is not officially supported but it should work in most cases. You should be able to install from P2 anyway (see description of https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=288872 which demonstrates that it should work).

Let us know if you are able to install it using P2
israel barroso selected this answer as the correct answer

Comments
israel barroso commented Mar 28 '14, 3:19 a.m.

Ok, thanks for all. I´m going to try it.I´ve found the p2 repository for 4.0.6.zip and I´m going to check it. Thanks for your work & time.

One other answer



permanent link
Abraham Sweiss (2.4k829) | answered Mar 27 '14, 12:09 p.m.
I I believe the RTC 4.2 client is only delivered with the bundled eclipse client from jazz.net and do not provide a method to install the plugin on existing eclipse 4.2 instances.

Comments
Tim Mok commented Mar 28 '14, 3:31 p.m.
JAZZ DEVELOPER

Under the 'All Downloads' for each release, there is a link to the p2 repo.

Your answer


Register or to post your answer.