It's all about the answers!

Ask a question

RTC Client Showing Stack Trace When Viewing Plan Work Breakdown


Cindy Davis (622) | asked Mar 21 '14, 3:50 p.m.

On a specific project for a specific team, viewing the Work Breakdown in the RTC Client results in the following being displayed:

org.mozilla.javascript.EcmaError: TypeError: Cannot read property "length" from null ({"Bundle-SymbolicName":"com.ibm.team.apt.shared.ui", "path":"\/resources\/internal\/quickquery", "name":"QuickQueryParser.js"}#516

  at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3557)

...

at org.mozilla.javascript.ScriptableObject.callMethod(ScriptableObject.java:1862)

at com.ibm.team.apt.internal.common.JSUtils.callMethod(JSUtils.java:50)

...

etc.

It looks like it starts with a CheckboxListViewer.widgetSelected (#498), goes to OutlinePage (#1769), and and then to QuickQueryParser (#67).

From previous posts, I get the idea that if a work item has an attribute set that is no longer defined in the process configuration, the RTC Client can have issues. Unfortunately, I have been unable to determine which item (if any) is causing the problem. I tried some of the published workarounds (searching for deleted priority enumerations and work item types), but did not find anything.

Anyone have any suggestions on what to do next?

One thing I found interesting/odd is that the error did not occur on other team displays until I displayed the team that causes the error. Then, none of the displays worked for any of the teams in that project until I restarted the RTC Client.

I am running RTC Client version 4.0.2.


Comments
Krzysztof Ka┼║mierczyk commented Mar 23 '14, 7:46 a.m.

Hi Cindy,
One clarification question: what do you mean by RTC client? Do you mean web browser ui? Or Eclipse client?


Cindy Davis commented Mar 24 '14, 10:20 a.m.

The Eclipse Client. The plan displays work fine in the web browser UI.

One answer



permanent link
Abraham Sweiss (2.4k1131) | answered Mar 31 '14, 3:18 p.m.
If the issue works in the WEBUI and only fails in the eclipse client, and that the client and server are both at 4.0.2 it may be a good idea to open a PMR.

Since it appears the issue is when viewing a plan and not when opening a workitem, I would look at the inline presentation editor and see if that needs to be tweaked.

Your answer


Register or to post your answer.