It's all about the answers!

Ask a question

RTC packaging (Enterprise Extensions) unable to create UCD component version

Louis Lock (3018) | asked Oct 19 '17, 10:09 a.m.

I specified the configurations in the package (enterprise extensions) definition to create a component version in UCD.  When executing the package,  I got the following in the log and no component version was created in ucd.  The UCD version initially set up was 6.1.0 and recently upgraded to  We are able to run the BUZRJCL job to manually create the component version in UCD.  Sounds like the UCD agent is working fine.  However, we want the UCD component version to be automatically created when the package is created. What property files is RTC having trouble with?  Any help would be much appreciated.  Thanks. 


      [echo] [exec] /usr/lpp/IBM/ucd/v6.2.3.1/ibm-ucd/agent/bin/ createZOSVersion -c 'Louis zOS Cobol' -s '/u/lock/DSTz_Scrum_Stream/Package/_vva7oJozEee5_7e_MwUb_g/20171012-1356180947/packageManifest.xml' -v '20171012-1356180947' -verbose
      [exec] Using toolkit configuration in /opt/ibm-ucd/agent/bin
      [exec] Component:Louis zOS Cobol
      [exec] Ship list file:/u/lock/DSTz_Scrum_Stream/Package/_vva7oJozEee5_7e_MwUb_g/20171012-1356180947/packageManifest.xml
      [exec] Version:20171012-1356180947
      [exec] Verbose:
      [exec] Unsupported option: ucd.agent.home=/opt/ibm-ucd/agent
      [exec] Failed to read properties from property file
*      [exec] Return code : 4

Accepted answer

permanent link
Sean Babineau (38825) | answered Oct 19 '17, 2:05 p.m.

 Hi Louis, are you able to invoke script on its own successfully? I think UCD's is reading some properties file (e.g. perhaps ${ucd-agent-dir}/conf/agent/ ? ) and doesn't like something it sees. 

~Sean Babineau

Louis Lock selected this answer as the correct answer

Louis Lock commented Oct 19 '17, 4:02 p.m.

Hi Sean, thanks for your response.  I've tried to execute but got the same error as previously posted.  I've taken a look at the file.  The file is in ASCII not EBCDIC.  Is it expected to be in ASCII?  Another observation is that the property file shows that mutual authentication is enabled "locked/agent.mutual_auth=true".  Am I correct that mutual authentication should not be a problem?  Thanks.

Sean Babineau commented Oct 19 '17, 5:11 p.m.

 Hi Louis, yes, the properties file is expected to be ASCII. Since invoking directly is failing with the same error, it looks like this is a UCD z/OS agent issue. My 6.2.6 and 6.2.5 UCD agents' files have the property locked/agent.home defined but not ucd.agent.home. I might check if ucd.agent.home is defined in yours; and whether changing it to locked/agent.home makes an improvement. Also, if this is an urgent issue, feel free to open a PMR with UCD. 

Louis Lock commented Oct 20 '17, 10:50 a.m.

Hi Sean, actually the file has locked/agent.home=/opt/ibm-ucd/agent not ucd.agent.home.  I'm trying to figure out where ucd.agent.home is defined.  So far, the only occurence of ucd.agent.home I could find was in BUZPROF within the ucdtoolkit/buzsamp folder.  I thought BUZPROF is only used when we run BUZRJCL.  Any additional thoughts?  Thanks.

Louis Lock commented Oct 20 '17, 1:20 p.m.

Hi Sean, finally I've got this resolved.  I've found there is an file under the ucd toolkit library defines mvs.profile=BUZ.SBUZSAMP(MYPROF).  I updated the MYPROF file by removing the parameter ucd.agent.home.  After this update, the packaging worked fine and ucd component version was created in ucd. Case closed.  Thanks for your help!

One other answer

permanent link
Tony (Zhang Hong) Chen (132) | answered Oct 20 '17, 2:43 a.m.

Hi Louis,   the error  Unsupported option: ucd.agent.home=/opt/ibm-ucd/agent  might be cause by the MVS data sets of the agent not being upgrade to  There's also a potential problem that you are running from /usr/lpp/IBM/ucd/v6.2.3.1/ibm-ucd/agent but using configuration from /opt/ibm-ucd/agent/bin.   If you don't have version data and deployment results to be preserved with this agent, I would recommend do a new agent install.  Thanks.

Louis Lock commented Oct 20 '17, 9:01 a.m.

Hi Tony, thanks for your response.  Currently, there is a symbolic link defined linking /opt/ibm-ucd to /usr/lpp/IBM/ucd/v6.2.3.1/ibm-ucd but I agree that it seems to be a problem with the ucd agent install.  I will try the suggestion from Sean to see if it works.  If  not, I will try to arrange to re-install the agent.

Your answer

Register or to post your answer.