It's all about the answers!

Ask a question

Eclipse RTC password

Yehiel Glass (25528886) | asked Jun 17 '12, 9:24 a.m.


I use RTC, WAS , LDAP, Eclipse 3.7 .

When I first create repository connection, I check the 'Remember my password' and it works excellent.

But when I change my password in LDAP, I can't reset the password in Eclipse: it always popup a login window.. I understand that RTC remember my old password .. :(

How can I reset (or delete) the old saved password in the eclipse so it will remember my new password and automatically login next time ?


Accepted answer

permanent link
Karl Weinert (2.0k52736) | answered Jun 20 '12, 2:58 p.m.
Is it the " secure storage password" pop up? If so I found this solution that worked for me
Based on this eclipse bug I did the following on Windows
  1. Close Eclipse
  2.  Delete c:\users\myusername\.eclipse\ directory
    ~/eclipse/ on Linux
  3. Create a text file containing the master password
    I created mine in the root of my eclipse install dir
  4. Add the following to the top of your eclipse.ini file in the eclipse directory
    Note these have to be on separate lines.
  5. Start Eclipse again.

Geoffrey Clemm selected this answer as the correct answer

6 other answers

permanent link
Karl Weinert (2.0k52736) | answered Apr 09 '13, 7:44 a.m.
edited Apr 09 '13, 8:12 p.m. by Geoffrey Clemm (30.1k23035)
I have some additional information since posting my first answer that might help.
When you save the password on eclipse it may also prompt you to create a master password.
On Windows this is done automatically based on your login.
I have found that when you change your windows password it can affect the "master password"
In turn you can't access your saved passwords. (you probably can't save them either but I'm not 100% sure of that)

To resolve this open eclipse go to:
Windows -> Preferences:
General -> Security -> Secure Storage
Highlight "Windows Integration" and click "Change Password"
The password update and you should be able to access\save passwords again.
Note When using the Windows Integration method you can just ignore the password recovery prompt.

permanent link
Arne Bister (2.6k12732) | answered Jun 18 '12, 2:27 a.m.

once login fails, go to the Work Item view of your Eclipse client. Under Repository Connection, right-click the connection for which you want to change the password. Choose properties --> Jazz Repository Connection. This will open the page in the property wizard that allows you to the change the password stored in the Eclipse client.

In Eclipse, you can find the actual storage for passwords by looking under Windows --> Preferences --> Security --> Secure Storage. There is also a button for clearing stored passwords. For me, the file sits at C:\users...\.eclipse\\secure_storage

Does this answer your question? Then please click on "accept answer".

- Arne

permanent link
Yehiel Glass (25528886) | answered Jun 18 '12, 6:27 a.m.

Hi Arne,

I already tried these two things but the login window always pop up ..

Anymore ideas ?


permanent link
Arne Bister (2.6k12732) | answered Jun 18 '12, 8:45 a.m.
Hi Yehiel,

for testing reasons, does this happen if you open Eclipse against a fresh workspace? If you remove the stored password from the physical security_storage file on disk?

If the problem persists, please open a PMR with IBM Rational support.
Good fortune in quickly getting to the bottom of the issue.

- Arne

permanent link
Yehiel Glass (25528886) | answered Jun 20 '12, 12:32 p.m.
I need to check what if I open fresh eclipse . If I remove the security file - it doesn't help.
PMR opened.
I will update you when I'll have something interesting.. :)

priya sekar commented Apr 09 '13, 4:31 a.m.

any update on the PMR. I am also facing the same issue

permanent link
Yehiel Glass (25528886) | answered May 12 '13, 5:16 a.m.


The problem disappeared . I don't know what exactly cause the problem and what solved it.

I closed the PMR. Maybe it was the Active directory (we use 2003 and not 2008 as written in the requirements.



Your answer

Register or to post your answer.