It's all about the answers!

Ask a question

RRC - Size limit to Word import into Module


Taly Hotimsky (2563357) | asked Mar 11 '14, 5:39 p.m.
We're running into a problem importing a Word document and converting it into a Module.
It'd happen every time, regardless of our choices to identify the requirements within the doc.
We were only able to import it once we broke it down into two smaller documents.

The total size of the original was 9.6MB. The two smaller ones were 2.2MB and 7.4MB.

Is there a known/documented size limit for the import functionality?

Comments
Taly Hotimsky commented Mar 11 '14, 5:56 p.m.

 In addition, is there a pages/word limit on the documents to be imported? 

3 answers



permanent link
Walter Cigana (1245) | answered Mar 11 '14, 6:02 p.m.
There is no limit that I know of, but if there is a limitation for the version of RRC that you're using, you should be able to find this documented in the release notes, under section: "Known problems and workarounds".

If you're using 4.0.6 the release notes are here: https://jazz.net/downloads/rational-requirements-composer/releases/4.0.6?p=releaseNotes

permanent link
Donald Nong (14.4k213) | answered Mar 11 '14, 6:49 p.m.
It's not about the size of the Word file - it's its complexity that matters.  You can have a small document that contains thousands of requirements, and a large one with hundreds of requirements but also lots of images. If you can let me know how many requirements you finally imported and how long it took, we may be able to say what might be the problem.
I tend to believe it's a performance issue at this stage but nothing definite until more information is available.

Comments
Taly Hotimsky commented Mar 11 '14, 6:57 p.m.

Hi Donald.


I ran into this problem with two files.

For the 1st one, split into two documents, the import summary was:
Artifacts: 562
Requirement: 530
Links: 11
Images: 52

For the 2nd one, split into three documents, the import summary was:
Artifacts: 448
Requirement: 488 
Links: 12
Images: 5
Comments: 4

However, in both cases, if with a single big file I choose a set up where no requirements would be identified (ie. no headings, no images, no keywords, etc) I still get an error when trying to run the wizard to the end (instead, I'd expect the summary to be displayed with all items with a 0).


permanent link
Daniel Moul (4.5k1115) | answered Mar 12 '14, 7:26 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
I wonder how much RAM you have allocated to the system running the RM application?  I seem to recall that the import process can require a lot of RAM.

Comments
Taly Hotimsky commented Mar 12 '14, 8:17 a.m.

Hi Daniel.


This happened both on the client (experienced by the client) environment and on the jazz.net sandbox (by me).

I can try to find out the info from the client env, but no idea how to figure out the sandbox configuration.
 


Daniel Moul commented Mar 12 '14, 8:54 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Since this is in the sandbox, it's probably not worth the effort to track this down the details. I'm glad there was a simple work-around. 

One take-away when planning a production deployment is this:  devote a generous amount of RAM to your RM application.  This will help with general performance as well.

Your answer


Register or to post your answer.