It's all about the answers!

Ask a question

CLM 4.0.4 QM - JTS version check error, help


sam detweiler (12.4k6181201) | asked Jan 21 '14, 4:12 p.m.
edited Jan 23 '14, 9:17 a.m. by Max Bridges (24126)
 we are cleaning up the logs as we work to full production cutover. 

we are seeing the following in the QM.log which is confusing

2014-01-21 08:37:50,094 [             JTS version check] ERROR ompatibility.internal.JtsConfigurationStateService  - CRJAZ2054E The Jazz Team Server version "2.0.0" is not compatible with this application. The Jazz Team Server version must be in the range [4.0.4,5.1).
 
2014-01-21 08:47:13,960 [qm: AsynchronousTaskRunner-1 @@ 08:47]  WARN com.ibm.rqm.defects.service                         - ChangeRequestCollector:hadInitialized AQXIN2503W Blocking defects cannot be automatically synchronized between the Quality Management application and the Change and Configuration Management (CCM) application. The integration of the applications is incorrectly configured.

the JTS version as seen from both the QM and JTS admin screens is 4.0.4 as expected. 

anyone know where this error might be coming from, things to check?
at the bottom of the Qm.log as part of startup we see

INFO com.ibm.team.repository.servlet.TeamServerServlet   - CRJAZ2076I Product Details:
  Quality Management - Core Libraries, Version 4.0.4 (I20130803_2347)
  Jazz Foundation - Core Libraries, Version 4.0.4 (RJF-I20130802-1652)

I do not see that version 2.0.0 message on any of our sandboxes,  only production landscape

Comments
Kevin Ramer commented Jan 21 '14, 5:18 p.m.

Sam, 
Do you have any forgotten "friends" or other application to application connections ?  That would be what I would check.

[ 5.1, so soon ....]

2 answers



permanent link
Paul Slauenwhite (8.3k12) | answered Jan 22 '14, 8:12 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
CRJAZ2054E: See:

https://jazz.net/forum/questions/110987/issue-crjaz2054e-the-jazz-team-server-version-is-not-compatible-with-this-applicationwhen-deploy-extensions-on-rtc-402

https://jazz.net/forum/questions/90469/crjaz2054e-the-jazz-team-server-version-is-not-compatible-with-this-application-the-version-is-4001-but-it-must-be-in-the-range-401510

https://jazz.net/forum/questions/64293/full-distribution-install-issue

AQXIN2503W: It appears the configuration for using a CCM application as your defect provider are incorrect.  See
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m4/topic/com.ibm.rational.test.qm.doc/topics/t_config_rtc_defects_overview.html.

Comments
sam detweiler commented Jan 23 '14, 11:35 a.m.

so far, nothing obvious and not upgraded, and installed from one bundle so architectures match.  


permanent link
Karl Freburger (1) | answered Jun 12 '14, 11:24 a.m.
JAZZ DEVELOPER
 Any resolution on this? What application thought the JTS was version 2.0.0.0?

Comments
sam detweiler commented Jun 12 '14, 4:04 p.m.

sorry for not updating, this looks like it was a QM config issue. I no longer work there, so cannot get you any details.  the net is, this was an incorrect message caused by the misconfiguration

Your answer


Register or to post your answer.