It's all about the answers!

Ask a question

Using RTC integration provider to automate a test execution in RQM


Sany Maamari (13342849) | asked Jan 25 '13, 11:13 a.m.
retagged Jan 29 '13, 7:51 a.m. by Laura Kuczarski (21137)
 Hello all, 

I've configured an RTC integration provider in RQM. I've got all my RTC build, but the status of these build is "Not Affected".

I want to automatically execute RFT scripts in RQM when a new build has succeeded. But even if I see the RTC builds, I do not see the status of the build. 
This disable to test automation to work because RQM never sees a succeed RTC build. 
We're using RTC and RQM 4.0. 

Does anyone met the same problem and found a solution ? 
Thanks for the help.
Sany

4 answers



permanent link
Rajat Singh (59833443) | answered Jan 26 '13, 8:52 a.m.
Hi

You might want to create an execution schedule to trigger the execution once the build completes.
This can be done by navigating from the dashboard Execution->Create Execution schedule.


You can refer to the below link for more information:
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/index.jsp?topic=%2Fcom.ibm.rational.test.qm.doc%2Ftopics%2Fc_build_ver_overview.html

Hope this helps!!

Best Regards
Rajat

Comments
Sany Maamari commented Feb 07 '13, 11:20 a.m.

 Hi Rajat, 

I've tried this on the Money That Matters sample lifecycle project and it worked. 
On my project, all my builds have unaffected status. DO you think that it is a problem on RTC side ? 


permanent link
Sany Maamari (13342849) | answered Jan 28 '13, 8:34 a.m.
 Hi Rajat, 
Thanks for the answer. That's what we do, but the execution never gets triggered because the result of the generation is never success in RQM even if it is in RTC. 

What's weird is that we see the RTC generation in RQM but not the results of the generation. 

Sany

permanent link
Roberto Bañuelos Avila (11) | answered Jan 22 '14, 5:24 p.m.
JAZZ DEVELOPER
Hi
The same issue here.
I setup the RTC Build Provider in my RQM project and scheduled my jobs but even the RTC build finishes OK the RQM schedule never starts.

What is the time frame of refreshing results from RTC to RQM? I wonder if this issue is related to that time frame.

Thanks!

Comments
Roberto Bañuelos Avila commented Jan 22 '14, 5:28 p.m.
JAZZ DEVELOPER

I forgot to mention that I also added a new build definition in my RTC but it doesn't appear in my RQM Build Definition list. That's why my question about the refreshing time.

Regards!


permanent link
Shravana Sainath (131) | answered Jul 06 '17, 7:23 a.m.

Hi Rajat Singh,
currently am facing the same issue " I also added a new build definition in my RTC but it doesn't appear in my RQM Build Definition list." as per Roberto Comment... Ive setup RTC Build Provider in RQM and integrated CCM PA with QM PA.
please help me out

Your answer


Register or to post your answer.