It's all about the answers!

Ask a question

RRDI 2.0.4 using WAS 8.0 installation issue


Narayanan Potti (27026069) | asked Oct 03 '13, 9:58 p.m.

I installed RRDI 2.0.4 on a VM running Windows Server 2008 R2. The server has WebSphere Application Server (WAS) 8.0. Both RRDI and WAS installed on this server are 32 bit.

WAS installlation location:  C:\Program Files (x86)\IBM\WebSphere\AppServer
RRDI installation location: E:\ProgramFiles

I was trying RRDI setup / configuration, on step 4 where I need to validate WAS settings I entered the installation location for WAS. However RRDI setup does not recognize WAS. I opened a PMR with Rational tech support and the tech support thinks it is a known problem when RRDI and WAS are installed on separate hard drives. Tech support suggested uninstalling RRDI and re-installing it in C:\Program Files (x86)\IBM\ where WAS is installed.

I wanted to know if anyone else faced this problem. Is this requirement documented, it appears a bug with RRDI ?

Any help would be much appreciated.

Thanks
npotti

3 answers



permanent link
Narayanan Potti (27026069) | answered Oct 08 '13, 5:42 p.m.
I got the solution for the PMR I had created with tech support. CLM 4.0.1 and WAS 8.0 were installed by a CM administrator who was on my project before I started working here. WAS 8.0 is installed in C:\Prgram Files(x86)\IBM\WebSphere folder and it led me to think it is 32 bit.  When I run the connand below to check WAS version:
C:\Program Files (x86)\IBM\WebSphere\AppServer\bin>versionInfo.bat  it result shows the information below indicating it is 64 bit. I had to uninstall RRDI 32 bit and re-install using 64 bit installation file. When I installed 64 bit RRDI in E:\ProgramFiles I was able to move ahead with the WAS configuration.

Installed Product
--------------------------------------------------------------------------------
 Name                  IBM WebSphere Application Server
Version               8.0.0.3
ID                    BASE
Build Level           cf031212.03
Build Date            3/20/12
Package               com.ibm.websphere.BASE.v80_8.0.3.20120320_0536
Architecture          x86-64 (64 bit)
Installed Features    IBM 64-bit SDK for Java, Version 6
                      EJBDeploy tool for pre-EJB 3.0 modules
                      Embeddable EJB container
                      Stand-alone thin clients and resource adapters
 





permanent link
Xuan Jiang (37858) | answered Oct 03 '13, 10:14 p.m.
Npotti - can you paste the error message and/or attach the rrdi_setup.log for future investigation?


Comments
Narayanan Potti commented Oct 04 '13, 7:59 a.m.

During RRDI setup it gave error - The WebSphere installation directory "C:\Program Files (x86)\IBM\WebSphere\AppServer" cannot be found. I tried to use the path C:\Progra~1\IBM\WebSphere\AppServer and got same error. I don't see the option to attach files here. Below are the errors from the setup log:

10/03/2013 17:34:07,560 ERROR com.ibm.rational.rrdi.setup.steps.CreateWASProfileStepService : CRRRA0063E: An error occurred while validating the WebSphere installation directory and HTTP port: CRRRA2045E: The WebSphere installation directory C:\Progra~1\IBM\WebSphere\AppServer cannot be found..
com.ibm.rational.rrdi.setup.biserver.common.RRDIBIServerException: CRRRA2045E: The WebSphere installation directory C:\Progra~1\IBM\WebSphere\AppServer cannot be found.


Xuan Jiang commented Oct 04 '13, 8:12 a.m.

Can you please run versioninfo.bat under your WAS directory like C:\Progra~1\IBM\WebSphere\AppServer\bin and paste the result here?


permanent link
Francesco Chiossi (5.7k1719) | answered Oct 08 '13, 4:51 a.m.
edited Oct 08 '13, 4:52 a.m.
Hello Npotti,

I would try installing WAS outside of the system folder C:\Program Files (x86) and possibly with no space characters in the PATH (e.g. C:\IBM\WebSphere\AppServer ).

Best Regards
Francesco


Your answer


Register or to post your answer.