It's all about the answers!

Ask a question

Why am I getting a -601 on CMOBJPROPS74 table when starting Insight WAS service after migrating from RRDI?


Michael Walker (99213194157) | asked Dec 03 '12, 3:44 p.m.
On a test system I'm trying out a migration from RRDI 1.0.2 to Insight 1.1 with CLM 3.0.1.3 prior to migrating the customer on their production system.  The CLM server, RRDI, Insight, and DB2 are all on the same server.  I have one id that is the admin for all the products for simplicity.

When I installed Insight I chose to manually install the report server so I could upgrade the existing DW and RICM dbs.  On the steps where you upgrade those DBs I ran both the install.bat files after modifying the parameters files.

After completing the steps following the db upgrade I started the WAS profile and tried to bring up Insight. I ended up getting the DPR-ERR-2109 error saying the dispatcher was still initializing. I looked in the cogserver.log and found this error occurs everytime I restart the WAS service.

Content Manager is unable to initialize the content store by using the initialization file "E:\Program Files (x86)\IBM\Rational Insight11\cognos\configuration\schemas\content\db2\dbUpgrade5_0004-to-5_0005_db2.sql". Review the configuration for the content store database in IBM Cognos Configuration to ensure that the settings are correct. Verify that the account used to access the content store is still valid by checking the status of the password and account permissions. Verify that the account that Content Manager uses has sufficient permissions to create, to connect to, and to initialize the file contents in the database.  The name of the object to be created is identical to the existing name "MIWALKER.CMOBJPROPS74" of type "TABLE".. SQLCODE=-601, SQLSTATE=42710, DRIVER=3.63.75 Cause: The name of the object to be created is identical to the existing name "MIWALKER.CMOBJPROPS74" of type "TABLE".. SQLCODE=-601, SQLSTATE=42710, DRIVER=3.63.75


I looked in the log folder for the content store ddl upgrade saw that the table was created successfully, although I see that many of the objects prior to CMOBJPROPS74 fail to create because they already existed. I assume this is because they were originally created for RRDI.



CREATE TABLE "CMOBJPROPS74"  ( "CMID" INTEGER NOT NULL , "DEPLOYREFS" CLOB(1048576) LOGGED NOT COMPACT , "LAUNCHTYPE" VARCHAR(512) , "SPEC" BLOB(1073741824) LOGGED NOT COMPACT ) IN "CTBS_4K"

DB20000I  The SQL command completed successfully.



ALTER TABLE "CMOBJPROPS74" ADD CONSTRAINT "PK_CMOBJPROPS74" PRIMARY KEY ("CMID")

DB20000I  The SQL command completed successfully.


I've verified Cognos Config is running correctly and I can connect to the Content Store.  All tests there work fine. I just don't understand why when I start the service it's trying to create that object again when it's already in the db.

Any help is appreciated...thx.

Comments
Michael Walker commented Dec 04 '12, 2:16 a.m.

bump bump bump?

One answer



permanent link
Xuan Jiang (37858) | answered Dec 05 '12, 2:38 a.m.
I believe this error was caused by in-completed RICM upgrade - this way the Content Manager still try to upgrade it during start, try this solution (I haven't tried that but hope it works).

  • Backup and then open the "E:\Program Files (x86)\IBM\Rational Insight11\cognos\configuration\schemas\content\db2\dbUpgrade5_0004-to-5_0005_db2.sql"
  • Modify and remove the CREATE TABLE CMOBJPROPS74 related lines
  • Save it and restart Reporting Server, check the log

Your answer


Register or to post your answer.