It's all about the answers!

Ask a question

wi workflow change is not inherited correctly by the child

Martina Riedel (20323341) | asked Jul 04 '13, 4:37 p.m.
edited Jul 04 '13, 4:42 p.m.
I have a master project and template and a bunch of children projects that use the master. All the children use the process form the master and show "unconfigured" for the Work Items sections, especially for the workflow.

I changed the workflow for story in the master (significantly) and as I am testing, the children kinda get it, but not quite. It looks like it is caching some old stuff somewhere.
In particular, I see the action "Verify" and instead of going to state "Verified" it changes to state "New".

When I click in the child on "Customize this Configuration Data" for workflow, everything works fine. After I delete the lines it creates in the child template, everything keeps working fine (it shows unconfigured again).

So I could click through all my children and do this, but I really don't want to. It beats the purpose of doing the change in one central location and be done with it.

I have done the work around for all the projects that actively use stories, but I have a bunch of children that currently don't use stories where I still need to do it and going forward, this isn't quite how I thought this works.

Any advice on how to force it to "reload" (or "uncache")

Accepted answer

permanent link
sam detweiler (12.5k6195201) | answered Jul 04 '13, 6:38 p.m.
on we saw a couple cases where we needed to restart the server clean to force the process config to update for children.

we decided never to edit the process config of a parent live.  we always deployed a new template and then reparented the child projects to the new master.
Martina Riedel selected this answer as the correct answer

Martina Riedel commented Jul 04 '13, 7:02 p.m.

Lovely. Was this ever reported (and accepted) as a defect?


sam detweiler commented Jul 05 '13, 8:44 a.m.

I do not think it was a defect. This is Oct 2011 timeframe. I think we reviewed the workaround, and changed our procedures.
We had just started using shared process configs.

Martina Riedel commented Jul 06 '13, 8:17 p.m.

Are you now on 4.x and did you reproduce it (or did you just stick to your procedures or ...) 

sam detweiler commented Jul 07 '13, 8:48 a.m. | edited Jul 07 '13, 8:50 a.m.

I was laid off (last month) as part of a mgmt staff change, before they upgraded to V4 (two weeks ago), but I doubt they would change procedures. this procedure meant we always knew exactly what process template teams were using, and we had a reliable change mgmt process.
(supporting 5000 users is no easy task).

One other answer

permanent link
Indradri Basu (1.8k1514) | answered Jul 04 '13, 4:59 p.m.
To clean the eclipse cache I would do the following:
From the manage project areas, deselect all the project areas and close eclipse client. Then right click on  the RTC eclipse client shortcut and select properties. In the Target textbox, add -clean at the end of the line and click ok.
This should clean the cache next time you open eclipse client.
Another option is to create a new workspace and see if you notice the same discrepancies.

Martina Riedel commented Jul 04 '13, 5:13 p.m.

if it was the client it would be even more horrible since t hen every user would have something cached.
I created a new eclipse ws and it is definitely not the client. It does the same thing in the web client.
There it doesn't "get" the action name and then sets it to "done".
So both clients are doing things not right, and the interesting thing is that they are doing them wrong in different ways

Indradri Basu commented Jul 04 '13, 5:24 p.m.

Hi Martina, if this behavior is consistent then I would suspect if something went wrong with the process configuration. You may want to open a PMR and report the problem to support.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.