It's all about the answers!

Ask a question

Jazz authentication change from Form to Basic on tomacat


Ashwath G (6622847) | asked Jan 27 '13, 8:11 a.m.
 Hello,

I am trying to change my JTS 4.0  authentication from "Form" to "Basic" on tomcat server ,integrated with LDAP.

If i am correct is these files are enough to change the authentication type

*  1) file path JTS\Server\Tomcat\conf\jts\web.xml  ( comment form type and un comment basic type)

** 2) File path JTS\server\tomcat\conf\Catalina\localhost\jazz.xml ( class name attribute "value")

(or)

*   Is it required to change the same in JTS\Server\Tomcat\conf\ccm\web.xml ....also?

** Is it required to change the same in  JTS\server\tomcat\conf\Catalina\localhost\ccm.xml ( class name attribute "value")?

When i did changes only with the 1 and 2 it given me the basic authentication window but with some initialization errors.

please clarify me on  this topic 

Thank you in advance

Ashwath

Accepted answer


permanent link
Bo Chulindra (1.3k2718) | answered Jan 28 '13, 10:54 a.m.
JAZZ DEVELOPER
If you want CCM to use BASIC auth, then you'll want to modify the ccm files as well.
Ashwath G selected this answer as the correct answer

Comments
Ashwath G commented Jan 29 '13, 12:59 a.m.

Thank you Chulindra ...

2 other answers



permanent link
Brian Fleming (1.6k11928) | answered Jan 27 '13, 8:18 p.m.
The comments at the end of this article: https://jazz.net/library/article/75
describe everything that needs to be changed.  I've pasted them below for reference.

Bo Chulindra wrote on September 26, 2012 04:35:37:

Note that if you follow the instructions to configure the server to use BASIC auth, you may see the following warning in Tomcat:

Mar 20, 2012 4:22:55 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Context/Valve} Setting property 'characterEncoding' to 'UTF-8' did not find a matching property

This is can be resolved by removing the characterEncoding attribute from the "Valve" element. After removing the attribute, the element should look like this:

<Valve className="org.apache.catalina.authenticator.BasicAuthenticator"
changeSessionIdOnAuthentication="true"
securePagesWithPragma="false"/>
Ian Wark wrote on October 16, 2012 11:04:40:

We believe it is necessary to do the below to change Tomcat application server to use BASIC authentication. Other settings explained above were not enough. For us, this made it possible to access RTC 3.0.x news feeds from Lotus Notes 8.5 and RSSOwl 2.1.4.

1. Shut down all Jazz servers.
2. Find every occurrence of:

<login-config>
<auth-method>FORM</auth-method>
...
</login-config>
in all files named "web.xml" under
[JazzServerInstallDir]/server/tomcat/webapps and replace it with:
<login-config>
<auth-method>BASIC</auth-method>
<realm-name>Jazz</realm-name>
</login-config>
The new text should already appear in the file in a comment.

3. Find every occurrence of
"org.apache.catalina.authenticator.FormAuthenticator" in all .xml files
under [JazzServerInstallDir]/server/tomcat and replace it with
"org.apache.catalina.authenticator.BasicAuthenticator".

4. Restart all Jazz servers.

Note that this will change the way Jazz authenticates all web clients as well, not just feeds.



Comments
Ashwath G commented Jan 29 '13, 1:00 a.m.

Thank you Ian ...its working fine ...


permanent link
Bo Chulindra (1.3k2718) | answered Feb 01 '13, 3:49 p.m.
JAZZ DEVELOPER
I should clarify here that the files mentioned in the question aren't correct for JTS 4.0. JTS 4.0 uses Tomcat 7, so there will not be the file

server/tomcat/conf/Catalina/localhost/<appName>.xml

Instead, it will be

server/tomcat/webapps/<appName>/META-INF/context.xml.

The other file to modify is

server/tomcat/webapps/<appName>/WEB-INF/web.xml

Your answer


Register or to post your answer.