It's all about the answers!

Ask a question

Progress of parent WI in plan view?


Yvo Van Wezemael (9912) | asked Dec 19 '12, 9:45 a.m.
JAZZ DEVELOPER
What exactly is the reason why some parent work items show now progress information with the info "The progress for this work item is computed only using its own information" while others show progress and show the child work items the information is calculated on?

I checked all planning related articles and forum entries but still does not get the reasoning behind that.

Accepted answer


permanent link
Guido Schneider (3.4k1384112) | answered Dec 20 '12, 4:31 a.m.

Have you uploaded some of the workitems and the parent/child links with help of the Eclipse CSV import?

Or have you upgrade from V.3.0.1 to V.4.0.x.x

If yes the ClosureTable is not updated with the parent/child links and the values from children are not summed up, because the parent/child link is missing in the closure table.

You can rebuild the closure table with repotools-ccm.bat -rebuildClosureTable, but just in offline mode. And it may need an hour.

See defect 242299  and defect 242970.

Yvo Van Wezemael selected this answer as the correct answer

Comments
Yvo Van Wezemael commented Jan 17 '13, 4:31 a.m.
JAZZ DEVELOPER

Yes, CSV import with parent/child links was the reason for the problems. Thanks.

One other answer



permanent link
Ralph Schoon (61.6k33643) | answered Dec 19 '12, 5:31 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
 Yvo, I would assume the ones that show no progress are not in the scope of the plan. I tried to explain some of the basics in https://jazz.net/library/article/589.

Comments
Guido Schneider commented Dec 20 '12, 4:31 a.m.

I think the issue with outplaced items and not summed up is solved in V.4.0, thanks to the new way how the links in the workbreakdown views are handled. In my case it works also for outplaced parents and outplaced children.

Your answer


Register or to post your answer.