It's all about the answers!

Ask a question

RQM reports display internal error after upgrade


Rajat Singh (59833543) | asked Dec 19 '12, 3:32 a.m.
Dear Team

After upgrading RQM 3.0.x to 4.0.1, we are unable to generate any OOTB reports in RQM.
We are getting the below error:



We have upgraded the report templates but still observe the same behavior for all the reports.

Please advice.

Best Regards
Rajat

5 answers



permanent link
Paul Slauenwhite (8.4k12) | answered Dec 19 '12, 9:46 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
 Hi Rajat,

Can you provide the RQM log (see https://jazz.net/wiki/bin/view/Main/RQMMustGather20#Gather_the_server_logs)?

permanent link
Jun Wang (6077) | answered Dec 20 '12, 11:26 p.m.
Is the configuration of report data warehouse correct?

permanent link
PRASANTA CHAUDHURI (11031625) | answered Jan 17 '13, 11:57 p.m.
I am getting the same .
If you have solved this -- Pl. let me know in details how you have solved it

Thanks in Advance.

PKC

praschau@in.ibm.com


permanent link
Rajat Singh (59833543) | answered Jan 20 '13, 7:14 a.m.
edited May 14 '13, 7:28 a.m.
Hi All

This seems to be a known defect if you are running WebSphere Application Server 8.0.0.5 or 8.5

There are two workarounds for this problem:
1. Use WebSphere Application Server 8.0.0.4 or earlier
2. Add the following to the Java options in WebSphere -Xjit:exclude={org/mozilla/javascript/UintMap.*}
Note the '.' after the UintMap value


Best Regards
Rajat

permanent link
Antoinette Iacobo (650712) | answered Nov 13 '13, 3:11 p.m.
Hi Rajat,
Can you confirm that this is what you did to resolve this in WebSphere: 
1.    Open the administrative console.
2.    Select Servers.
3.    Select Application Servers.
4.    Select the server you want to configure.
5.    In the Additional Properties area, select Process Definition.
6.    In the Additional Properties area, select Java Virtual Machine.
7.    Add this to the list of the generic JVM arguments :  -Xjit:exclude={org/mozilla/javascript/UintMap.*}
You should see others such as -Xmx4g -Xgcpolicy gencon etc. for a CLM installation. So add it to the list.  Then you restart the application server. 



Comments
Christine POISVERT commented Jan 14 '14, 9:00 a.m.

Hi, I have the same issue and even if I have added this JVM arguments the problem is still there.... Can someone help me ?


Vidya Malkarnekar commented Jan 14 '14, 11:47 a.m.
JAZZ DEVELOPER

 As per technote http://www-01.ibm.com/support/docview.wss?uid=swg21616615, the issue is resolved in later Fixpacks of websphere  ( 8.0.0.6 and 8.5.0.2). Please upgrade.

Your answer


Register or to post your answer.