It's all about the answers!

Ask a question

Why are new custom attributes not displaying in both RTC client and web UI?


Andrew Trobec (49712140139) | asked Nov 06 '12, 12:52 p.m.
Hello All,

I am using RTC 3.0.1.1.

I have a custom work item that has a series of custom attributes associated with it.  I have recently added new attributes and put them in a new tab and a new section within the presentation.

Now that I have saved the project area, the work items does not display the attributes within the section of the new tab!  I see the new tab in both client and UI for both new and existing work items, but the attributes are not visible.  This is not the first time that I am adding new attributes to this work item so I don't understand why it is not working.

After logging out, refreshing, clearing cache, I can sometimes view the new attributes, but they do not load properly.  Instead of being able to insert data, the enumeration and contributor lists do not load at all and appear in a sort of blocked state.  Most of the time, though, the attributes simply do not appear.

Does anybody have any ideas?

Best regards,

Andrew

Accepted answer


permanent link
Ralph Schoon (61.6k33643) | answered Nov 07 '12, 2:54 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Andrew, a typical issue is that custom attributes you create are not automatically available for work items created before the custom attributes where created.

If you create a new work item you should be able to see and edit the attributes, provided your presentations work as typical.

Please see this article for how to synchronize attributes: https://jazz.net/library/article/529

After this, your attributes should show up in older work items - in case that is the issue you are seeing here.
Andrew Trobec selected this answer as the correct answer

Comments
Andrew Trobec commented Nov 07 '12, 3:12 a.m.

Hello Ralph,


Thank you for the reply.

I have checked and it seems indeed that the attributes are available to new work items.

I have followed the article that you provided, but I don't have the "Synchronize Attributes" option available from the query in my RTC client.

Is there any other way to update the existing work item attributes?  I am using RTC 3.0.1.1.

Best regards,

Andrew


Ralph Schoon commented Nov 07 '12, 3:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please search for Sync. The topic is called "Applying Work Item Attribute Changes to Existing Work Items" in https://jazz.net/library/article/529.


Ralph Schoon commented Nov 07 '12, 3:17 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The only other option would be using the plain Java Client Libraries. I plan a post on that. However, the amount of work is way bigger than using the Eclipse UI.


Andrew Trobec commented Nov 07 '12, 3:52 a.m.

Thanks Ralph.


The trick is to right click on the Type column in the query.  I didn't have that column.  Once I added it everyone went ok.

Best regards,

Andrew 

One other answer



permanent link
sayli Boralkar (155) | answered Feb 24 '17, 5:27 a.m.

 This link is really helpful. thanks 

Your answer


Register or to post your answer.