It's all about the answers!

Ask a question

CRJAZ1840W The driver "oracle.jdbc.OracleDriver" could not be loaded and registered. This JDBC driver jar must be provided in a path configured by the server scripts. Please ensure that the driver is in the expected location of "/var/rdm/opt/ibm/DesignMa


Mark Ireland (26115548) | asked Oct 15 '12, 8:49 a.m.
Hi,

I am trying to set up RDM 3.0.1 with oracle 11g. Both myself and the DBA are 100% sure we have the correct odbc5.jar file.
Set up is 64 bit linux, using tomcat.

Error is :-

CRJAZ1840W

The driver "oracle.jdbc.OracleDriver" could not be loaded and registered. This JDBC driver jar must be provided in a path configured by the server scripts. Please ensure that the driver is in the expected location of "/var/rdm/opt/ibm/DesignManagement/oracle" or consult product setup instructions to change the location.

Regards 

Mark

Comments
Anthony Kesterton commented Oct 15 '12, 11:38 a.m.
JAZZ DEVELOPER

Apologies if you have already checked this - but are the permissions on the driver ok (for example - can the user or service that starts the server has read/execute access to the driver.

Are you using Oracle on another jazz-based product?

anthony


2
Bo Chulindra commented Oct 15 '12, 12:11 p.m. | edited Oct 15 '12, 12:13 p.m.
JAZZ DEVELOPER

@irelandm: can you try something this? I found this in an old work item:

"Set the environment variable ORACLE_JDBC_DRIVER_FILE to point to the JDBC driver JAR file (not the directory that contains the file). For example, if the ojdbc5.jar file is located in the <JazzInstallDir>/server/oracle directory, then ORACLE_JDBC_DRIVER_FILE must be set to <JazzInstallDir>/server/oracle/ojdbc5.jar."

This is for Jazz Team Server though. I'm not sure how DM figures out where the jar is.


Karl Weinert commented Oct 15 '12, 2:29 p.m.
JAZZ DEVELOPER

Bo's suggestion just worked for me on Windows with ojdbc5.jar

Accepted answer


permanent link
Mark Ireland (26115548) | answered Oct 16 '12, 7:44 a.m.
Hi,
The answer to this was :-

Update... the error above is to do with ORACLE ACL set up, I have found the following on interweb :-

it seems you have enabled ACL on the listener.

You can follow these steps to avoid the error:


1. Go to directory $ORACLE_HOME/network/admin

2. Modify sqlnet.ora file with following parameter:
tcp.validnode_checking = no

3. If you don't want to disable this, you can put the machine names as follows:

tcp.invited_nodes=(machine1, machine2)

3. Bounce the listener.


Many thanks all.
Daniel Leroux selected this answer as the correct answer

8 other answers



permanent link
Mark Ireland (26115548) | answered Oct 15 '12, 12:06 p.m.
Hi,

Yes I have, but many thanks for responding, it is the obvious that we have probarly missed.
We have also tried 4 different files, and ensured file set to 777 (same thoughts as Anthony!)

Ta

Mark

permanent link
Karl Athanasiou (3121217) | answered Oct 15 '12, 12:39 p.m.
Mark,
If you are running 11g on a 64 bit platform shouldn't you be using odbc6?
I remember issues I had with JTS failing with strange issues.
I moved to the latest 64 odbc6 and the errors went away.

permanent link
Michael Afshar (7014) | answered Oct 15 '12, 2:21 p.m.
JAZZ DEVELOPER
The required JDBC driver is ojdbc6.jar. Here is the help topic for more info:

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/topic/com.ibm.jazz.install.doc/topics/t_s_server_installation_setup_oracle.html

permanent link
Mark Ireland (26115548) | answered Oct 16 '12, 4:31 a.m.
Hi,

This is DM Version 3.0.1 not V4. Also I did place ojdbc6.jar alongside ojdbc5.jar JIC.

Ta

Mark

Comments
Anthony Kesterton commented Oct 16 '12, 5:08 a.m.
JAZZ DEVELOPER

Hi Mark - I have a vague memory of a similar discussion around Oracle and one of the jazz products, but it may be irrelevant.  I thought the odbc version is linked to the version of Oracle, not the software using Oracle.  Let me check on this - and will post here if I find anything useful.


Anthony Kesterton commented Oct 16 '12, 7:44 a.m.
JAZZ DEVELOPER

Mark - if your ACL changes don't work - we managed to fix a similar problem for RTC v3 accessing Oracle 11g by doing the following:

Created a sub-directory called oracle in the /server directory.
Added in the oracle drivers to the oracle sub-directory.

In this specific case we had to use an ojdbc5.jar driver - and we set up a symbolic link so the ojdbc14.jar actually pointed to the ojdbc5.jar (this was on Linux).

This may be completely irrelevant to your problem but adding in for completeness.

anthony



permanent link
Mark Ireland (26115548) | answered Oct 16 '12, 5:02 a.m.
Hi,

I made a change to the startup script, added a export for the ORACLE_JDBC_DRIVER_FILE variable point directly to the ojdbc5.jar file. I now have a different error ....

IO Error: Got minus one from read call

Any ideas?

Mark

permanent link
Mark Ireland (26115548) | answered Oct 16 '12, 5:12 a.m.
Hi,

Update... the error above is to do with ORACLE ACL set up, I have found the following on interweb :-

it seems you have enabled ACL on the listener.

You can follow these steps to avoid the error:


1. Go to directory $ORACLE_HOME/network/admin

2. Modify sqlnet.ora file with following parameter:
tcp.validnode_checking = no

3. If you don't want to disable this, you can put the machine names as follows:

tcp.invited_nodes=(machine1, machine2)

3. Bounce the listener.


I have asked our DBA to look at oracle server, I will let you all know if this works. Thanks again for the kind assistance.

permanent link
Anthony Kesterton (7.5k5177136) | answered Oct 16 '12, 5:15 a.m.
JAZZ DEVELOPER
Hi Mark

I should have checked this in the first place - system requirements for DM v3.0.1 only list Oracle 10g as a supported database:

http://www-01.ibm.com/support/docview.wss?uid=swg27021993#Rational_Software_Architect_Design_Manager_3_0_Databases_sw

This might be the underlying problem.  However, let me continue to dig on this - there may be a solution.

anthony

permanent link
YOGESH LOKHANDE (10441926) | answered Nov 07 '12, 5:35 a.m.
Hi all
I have same error with SQL server 2008 and was 7.0.17 and CLM 3.0.1

CRJAZ1840W 

The driver "com.microsoft.jdbc. Sql Driver" could not be loaded and registered. This JDBC driver jar must be provided in a path configured by the server scripts. Please ensure that the driver is in the expected location of "c://---------" or consult product setup instructions to change the location. 

Your answer


Register or to post your answer.