It's all about the answers!

Ask a question

ccm_upgrade.bat usage


T M (8876184143) | asked Aug 23 '12, 1:37 p.m.

WAS as the app server. The usage as per the upgrade instructions in the Info center:

upgrade\ccm\ccm_upgrade.bat -oldApplicationHome "C:\IBM\ CCM_3.x \server\conf" -newJTSHome "C:\IBM\JTS_4.0\server\conf"  -oldJTSHome "C:\IBM\JTS _3.x \server\conf"

"-oldJTSHome" is a required parameter? ccm_upgrade.bat doesn't seem to take it!

Thanks!

Accepted answer


permanent link
Ralph Schoon (56.5k23642) | answered Aug 23 '12, 6:30 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi TM leave it out. I ran into the same issue and there is a work item against documentation I created. This applies to JTS, RTC and RQM. Try with the parameter first. If it complains leave it out. Sorry, about that, I had the same strange feeling you probably have, but if I left it out, everything worked like a charm.
T M selected this answer as the correct answer

5 other answers



permanent link
Rosa Naranjo (2.8k11420) | answered Aug 27 '12, 11:22 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
edited Aug 27 '12, 11:26 a.m.
The part where the upgrade script provides this message is where it is trying to do something with your index files from your previous installation's (301x) configuration.  You will have to look at the 2 properties in teamserver.properties that indicate index file location:
The JFS indices (com.ibm.jfs.index.root.directory)
fulltext indices (com.ibm.team.fulltext.index.location)

In order to avoid a re-index which can take a long time depending on the size of your repository, the upgrade script attempts to copy over your previous indices from the 301x to the 40 directory.  Since this is WAS, see the link below for a walkthrough example and some explanations on what to do based on whether you had a relative or an absolute directory path location for your property values above.

if you wish to avoid the access denied error, perhaps you need to run the cmd prompt as an Administrator.  If it still does not work, then proceed to handle the index files transfer and update of the index file locations for your 40 configuration MANUALLY.

As Ralph stated, you can continue with the next upgrade steps like addTables and just perform the copy manually.

See the CLM 2012 upgrade guide and search for 'index location' for more details and background info.

permanent link
T M (8876184143) | answered Aug 26 '12, 10:36 a.m.

Please see below. All the config files are merged successfully and I still get "Access denied" message. Why is this?

Thanks!

The configuration files are merged successfully.

A notepad editor will be opened to let you verify the JTS teamserver.properties
file.
Verify that the Public URI root denoted by the com.ibm.team.repository.server.we
bapp.url property is correct.
Verify that the database properties are correct.
When done, save your changes if any and close the editor to continue the script
execution.

Consult the 'Upgrading the Jazz Team Server and the CLM applications' topic of t
he InfoCenter
for information on how to properly configure each property:
http://publib.boulder.ibm.com/infocenter/clmhelp/V4r0/topic/com.ibm.jazz.install
.doc/topics/t_update_prepare_config.html

Enter [C] to continue the execution or hit [Enter] to cancel the script executio
n:
C
Access denied


Step 1: Add tables
------------------

Directory: "C:\IBM\JazzTeamServer_4.0\server"
Command:
    repotools-jts.bat -addTables


permanent link
Ralph Schoon (56.5k23642) | answered Aug 27 '12, 3:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi TM,

you are probably seeing https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=215288

I ran into the same thing and I am not sure what it is, however, I was able to continue the upgrade and finished it successfully. I will try to get someone to look at the work item.

permanent link
T M (8876184143) | answered Aug 28 '12, 3:28 a.m.

Correct parameters:

upgrade\jts\jts_upgrade.bat -updateTomcatFiles=no -oldJTSHome "C:\IBM\JTS _3.x \server\conf"

upgrade\ccm\ccm_upgrade.bat -oldApplicationHome "C:\IBM\ CCM_3.x \server\conf" -newJTSHome "C:\IBM\JTS_4.0\server\conf" 

In the help, -oldJTSHome parameter is given to ccm_upgrade.bat rather than to jts_upgrade.bat


Comments
Ralph Schoon commented Aug 28 '12, 11:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi TM, please read Rosa's anser, if you did not already. Be aware that if the access denied happened, you have to manually copy the index files over. If you have proceeded to use your upgraded repos without doing this, you will probably have to run a reindex at some time.


permanent link
Michael Afshar (7014) | answered Aug 31 '12, 1:24 p.m.
JAZZ DEVELOPER
 The help topics were corrected and the info center will be refreshed in the next release.

Your answer


Register or to post your answer.