It's all about the answers!

Ask a question

Extension Workshop - Upgrade RTC V3.0.1 to V4.0


Anita Jey (1611215) | asked Jul 17 '12, 9:45 a.m.
edited Jan 18 '13, 3:21 a.m. by Ralph Schoon (55.5k23642)
I have RTC 3.0.1, that needs to be moved up to V4. 

When I set up 301, I used the workshop pdf, the tar files etc available at this link:  https://jazz.net/library/article/634 Apparently the equivalents of the tar files are not published yet :(
I am wondering if it is better to uninstall and re-install the whole thing or maybe just do an upgrade by updating the SDKs. The former is probably more straightforward, even if it also consumes more time.

Has anyone done this before? Any tips, ideas, suggestions? Thanks for your time.

Accepted answer


permanent link
Ralph Schoon (55.5k23642) | answered Jul 17 '12, 10:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jul 17 '12, 10:28 a.m.
Hi Anita,

the tar files are really only needed if you need to follow the workshop and work with the repository workspace.
If not, just go ahead and set it up fresh following Lab1 and using the 4.0 downloads.

You can try to import the 3.x tar files, I have not tested if that works. The other option would be to do a real upgrade to a 4.0 from the 3.0.1 server. I would suggest to use a new folder e.g. C:/RTC40Dev I do that and I have the dev environment for 3.x and 4.x on the same machine.

There is a new feature based launches jar up there, you can use. I downloaded it and it ended up having the extension .txt. I fixed that and it deployed well in the dropins folder. The launches that come with it are not necessary, you can use the ones that come with the workshop. Just import the project and replace the xml files.
There is an error showing with the launch for the JUnit to setup the DB. Ignore it. The missing bundle is not needed for the JUnit tests.

I am talking to our Web Dev team to get the update published this week, if at all possible.

Anita Jey selected this answer as the correct answer

2 other answers



permanent link
Ralph Schoon (55.5k23642) | answered Jul 17 '12, 10:03 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jul 17 '12, 10:03 a.m.
Hi Anita,

I am working on getting the update published. My findings are at the end of the comments section of the article.
You could upgrade the existing database to 4.0 in a new deployed server. That would be the easiest way of doing it, until we can get the new version out. The upgrade would take less than an hour.

If you only want to set up a development environment, you can essentially follow the existing workshop and take my finding in the comments into consideration. Then you can import your existing extensions there.

Comments
Anita Jey commented Jul 17 '12, 10:19 a.m.

Thanks Ralph. I need to set up a 4.0 Development environment. I am going to try installing it on a new machine, and will follow the 3.0.1 workshop pdf, and pick up the downloads for 4.0 instead. Also, I will use the 3.0.1 workshop tar files available at that url.

As far as I can tell, the gotchas are: 1. The feature based launches jar has a problem 2. Switch text file encoding to UTF-8

If I missed anything, please let me know. Thanks much!


William Hunsicker commented Jan 17 '13, 2:27 p.m.

I just attempted to do this as I needed to also follow the workshop.  4.0.1 installed just fine, but when I went to import the tar files, I ran into two problems.  The QM file could not be imported as the repotools-qm.bat file did not exist in the server directory.  The second problem I encountered was that the CCM and JTS files imported, but got an error "CRJAZ2403E The version of the data that you are trying to import does not match the version of this tool.  The "com.ibm.team.repository" component in the exported file uses version "28". However, this import tool can handle only version "32"." when importing.  Any idea when those files will be available?


Ralph Schoon commented Jan 17 '13, 5:19 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If you follow the Extensions Workshop you have to use the version it is released for. You can not use it with 4.0.0.1 and not with 4.0.1 as far as I can tell. Either use the version it is release for, or set it up with that version and then upgrade the repo after the repo-import. If you do that, be prepared that license plugin names might be named slightly different and you have to search for stuff.


permanent link
Ralph Schoon (55.5k23642) | answered Jan 18 '13, 3:02 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jan 18 '13, 3:21 a.m.
As a sidenote, https://jazz.net/library/article/1000 is the latest version of the workshop. It works with the 4.0 GA Version.

Your answer


Register or to post your answer.