It's all about the answers!

Ask a question

Shared resources directory and RTC 6.0.2 client for Eclipse 4.2.x

Gidi Gal (962057) | asked Aug 16 '16, 9:07 a.m.
edited Aug 16 '16, 10:55 a.m. by David Lafreniere (4.8k7)
Hello to the forum members,

I develop a client extension for RTC. When I install RTC 6.0.2 client for Eclipse 4.2.x (from the repository) it installs most of the plugins to shared resources directory and not under the folder I set for the installation. This causes issues with an extension I have to org.eclipse.ui.startup. This extension is not activated when RTC starts. In plugin.xml  there is message "No schema found for org.eclipse.ui.startup". After I reinstalled the message disappeared, but the issue remains, the extension is not activated on start-up.

Is there a way to install all RTC client under the path I set ?

By the way, the same issue is with RTC client 6.0.3 M4 for Eclipse 4.2.x. In 6.0.3 I also have issues with the views under "Work items" perspective. I get errors like "Could not create the view:".


Accepted answer

permanent link
Donald Nong (14.5k614) | answered Aug 17 '16, 3:17 a.m.
When you say "installed", do you mean using Installation Manager? If so, try the plain zip version, of the p2 installation method.
Gidi Gal selected this answer as the correct answer

Gidi Gal commented Aug 17 '16, 6:33 a.m.

Hello Donald,
Thanks for your reply on this issue. Yes, I installed through IBM installation manager. I tried installing the P2 for Eclipse 6.0.3 M4 on Eclipse 4.2.2 SDK 64 bit. There are two issues (I stopped there and turned to look at 6.0.2 instead):
1. The "Work Items" perspective is missing.
2. When I tried to set as my target platform the RTC SDK I got the following message:
"You have selected a target with a newer version than your current Eclipse installation. This can cause unexpected behavior in PDE. Please use a newer version of Eclipse."

I'll now try the same thing with RTC 6.0.2, will update soon about my findings.

Thanks again,

Gidi Gal commented Aug 17 '16, 9:00 a.m.

I managed to run my plugin on RTC 6.0.2 client installed from P2 repository. I got a message "Warning: You are signing content that contains unsigned content..." which is weird, since 6.0.2 was already released.

One other answer

permanent link
Krzysztof Kaźmierczyk (7.5k477103) | answered Aug 17 '23, 5:20 a.m.

 I had the "Could not create the view:" in version 7.0.2. The root cause was, that there were multiple org.apache.httpcomponents.hhtpclient, and org.apache.httpcomponents.hhtpcore jar files, each one in few, different versions. Removing one of the version of the  (or changing the extension for them) resolved the issue.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.