It's all about the answers!

Ask a question

Server Launch for RTC1.0.1 anyone?


Ralph Schoon (59.4k23642) | asked Nov 28 '08, 12:42 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi,

I am not sure the .Launch from https://jazz.net/wiki/bin/view/Main/JazzServerRunAndDebug
is working with RTC 1.0.1 (it seemed not to work for me).
Does anyone have a current one?

Thanks,


Ralph

Accepted answer


permanent link
Chris Daly (61651) | answered Dec 03 '08, 3:48 p.m.
JAZZ DEVELOPER
Ralph Schoon wrote:
Hi Patrick,

-Declipse.ignoreApp=true -Dosgi.noShutdown=true


This is already part of the config. I added some required bundles and
obviously I added too many. It works but throws some exceptions like


I made a pass trying to figure out the minimal differences needed to use
the wiki instructions (which were written in the 1.0 timeframe) with
1.0.1. Here is what I came up with - basically just gleaning clues
provided by Patrick, Matt and others here and trying to reduce to
something minimal:

1) found com.ibm.team.rtc.server.license.standard-trial_1.0.1.jar (in
RTC-Standard-Server-1.0.1-Trial-Win.zip download) and copied it to
....\jazz\client\eclipse\source\server\eclipse\plugins
Make sure it shows up in target platform (may need to reload TP).

2) using JazzServer-06-RTC10-Maximal.launch, added these to selected
bundles:
com.ibm.team.rtc.server.license.standard-trial
com.ibm.team.repository.rcp.common

3) added to launch config args:
-Declipse.ignoreApp=true
(not sure what this does and if it is really necessary)

With that I was able to start the server, connect with the browser,
login as ADMIN and poke around. Your mileage may vary. I see no
exceptions in the console. I'll attach my console output for reference


Chris
Ralph Schoon selected this answer as the correct answer

3 other answers



permanent link
Ralph Schoon (59.4k23642) | answered Nov 28 '08, 2:52 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
To be more precise,

I'd need a lauch for RTC with Eclipse 3.4 Ganymede. I got my launch to work
enabling additional bundles, but now I get errors.

Thanks,

Ralph

Hi,

I am not sure the .Launch from
https://jazz.net/wiki/bin/view/Main/JazzServerRunAndDebug
is working with RTC 1.0.1 (it seemed not to work for me).
Does anyone have a current one?
Thanks,

Ralph

permanent link
Ralph Schoon (59.4k23642) | answered Nov 28 '08, 4:35 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Patrick,

-Declipse.ignoreApp=true -Dosgi.noShutdown=true


This is already part of the config. I added some required bundles and obviously
I added too many. It works but throws some exceptions like

ERROR] 2008-11-28 14:21:07.234 - FrameworkManager: (SAT-110.1101) A framework
error has occurred.
org.osgi.framework.BundleException: The bundle could not be resolved. Reason:
Another singleton version selected: com.ibm.icu_3.8.1.v20080530
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)
2008-11-28 14:21:07.250 - FrameworkManager: (SAT-110.1101) A framework
error has occurred.

but it seems to be OK and running now. I will try to get rid of the exceptions
eventually.

Thanks,

Ralph

permanent link
Patrick Streule (4.9k21) | answered Nov 28 '08, 8:28 a.m.
JAZZ DEVELOPER
To be more precise,

I'd need a lauch for RTC with Eclipse 3.4 Ganymede. I got my launch to
work enabling additional bundles, but now I get errors.


Try adding

-Declipse.ignoreApp=true -Dosgi.noShutdown=true

to the launch config.

HTH
--
Regards,
Patrick
Jazz Work Item Team

Your answer


Register or to post your answer.