It's all about the answers!

Ask a question

Updating Installed CLM Help

Alan Murphy (531414) | asked Jun 27 '12, 10:39 a.m.
We've installed the full clmhelp application so that we've got help available for everyone, especially for those with no internet access.
The problem we have is updating it.  It seems that in order to update the installed clmhelp, we need a browser and internet access on the physical server.  Neither of which we have.  In corporate environments, its common place for servers to be stripped down versions of the OS.  Our 'gold' build of linux doesn't have any x-windows or browser and has no internet access.  How can we upgrade the clmhelp system we've installed ??

Alan Murphy commented Jun 29 '12, 4:04 a.m.

John, It's an immediate and ongoing concern since we can't see a way to update the help system with the constraints we have short of reinstalling a complete help system again from time to time when they become available.

4 answers

permanent link
Stefan Hoffmann (14421820) | answered Jun 29 '12, 2:51 a.m.
I currently maintain such an clmhelp environment with RTC 4.0:

1. You have to get access to the application via to update/modify the content of the help system, this is needed due some security policies and is a bit annoying (the server app checks that you are coming from I solve this with port forwarding with my ssh client and using my local browser, but you MUST use as local address, "localhost" doesn't work (at least in my environment).

2. As our server has no internet connection, I have to disable the default installed remote site or the help application always tries to get into internet, which extremely slows down access to the help. You can configure this with this url: There should be one site, disable or delete it.

3. You have to install the help system. First you can download a offline version at this URL at ibm:
For the CML 4.0 solution the file is

Extract this site on your server, and add the site to your help system with the url
For the 4.0, I removed the current installed help first, as it collides with the downloaded one. There is a "add" button where you can add the downloaded local "site.xml", e.g. /opt/clmhelp40/site.xml. Add the site to the installed ones and there you go.

Alan Murphy commented Jun 29 '12, 4:04 a.m.

Stefan, we're using RTC at the moment but will be looking to move to RTC 4 laterin the year. I'll take a look at your suggestion and see if it applies to RTC 3.x as well - thanks

Dustan Daniel commented Sep 21 '12, 4:00 a.m. | edited Sep 21 '12, 4:00 a.m.

Great post Stefan, exactly what I was looking for. The only additional step I needed was to add a signed.applets.codebase principal support boolean to my Firefox config, however the help updater provided steps to do this. Our CLM deployment was on Linux using the standard Firefox browser.

permanent link
John Suchy (1612) | answered Jun 28 '12, 3:48 p.m.
edited Jun 28 '12, 3:50 p.m.

Alan, is this an immediate need? (Are you trying to apply a specific update, or is this a future concern?)

We anticipate that other clients will encounter similar situations, so we should provide a standardized solution. We have a few options under consideration, but we want to deliver a solution that meets all relevant security requirements.

Alan Murphy commented Jul 02 '12, 4:25 a.m.

Hi John, Yes, it's an immediate and ongoing concern since we can't see a way to update the help system with the constraints we have short of reinstalling a complete help system again from time to time when they become available.

permanent link
Der M (6121418) | answered Sep 21 '12, 6:46 a.m.

Just to add a note to this.  I have been trying the URL

https://hostname:9443/clmhelp/updater/updatewar.jsp  (note hostname as server name) and in IE and this would not work.  404 error.

It was not until I tried  in Fire Fox 10 ESR that the page loaded and I was able to get the dialog to update my help.  Once I had pasted in the full file path (site.xml) into the dialog did my update work.  Oh and I first had to remove the installed help using the checkbox, first.

Hope this helps folks!!

Guido Schneider commented Jan 13 '13, 5:00 a.m.

I had the same on WIndows 2088-R2.

I then added  localhost
to etc/hosts file. After this I was able to use localhost.
In Windows 2008-R2 this entry is commented out in the default hosts file, after OS installation.

permanent link
Hadar Hawk (1882214) | answered Jan 15 '13, 9:20 a.m.
We have documented how to remotely administer the CLM help in this wiki topic:  Please let us know if you have any problems.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.