It's all about the answers!

Ask a question

Report 'Requirements Traceability' throws 'Required parameter Project is not set' error


Mohan K M (1111511) | asked Jun 21 '12, 3:42 a.m.
retagged Aug 27 '13, 2:52 p.m. by Ralph Earle (25738)
Hi All,
I have CLM v3.0.1.3 installed and a CLM project created with a collection on RM, a Test plan on QM and a sprint plaon CCM created. I can them all configured properly with an in-line editor working perfectly fine wherever appropriate.
  1. have a requirements link section QM associated with a collection properly
  2. Have couple of Test cases created with requirements associated properly for each
  3. have TERs created and executed with a failure reported and defect created on CCM
But when I try to run report, 'Requirements Traceability'  throws 'Required parameter Project is not set' error though I have selected the project parameter properly. I have observed this behaviour consistently on IE v8, FF v10 and chrome. Any guidance/pointer would really help. Thanks


4 answers



permanent link
Robert Rassmann (9923) | answered Jun 25 '12, 3:57 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
I tried this on my server and the report runs successfully.  I'd check t make sure the ETLs have run successfully.  Also, if this is a migrated database check to make sure that you didn't miss any of the steps required in the migration.

permanent link
Mohan K M (1111511) | answered Jun 26 '12, 4:07 a.m.
Thanks Rob; Its a fresh instance. Looks like I have an issue with my 'Requirements job'

permanent link
Michael Alberda (251627) | answered May 13 '13, 7:17 a.m.
Hi Mohan,

Did you ever resolve this issue as i am currently faced with the same error?

Kind Regards,

Michael Alberda

Comments
Dustan Daniel commented May 14 '13, 3:25 a.m.

permanent link
Jun Wang (6077) | answered May 15 '13, 12:01 a.m.
It is an known defet RQM: Requirement Traceability Report fails: (78990) and has been resolved in 3.0.1.6 and the coming 4.0.3. In 4.0.2, we have a release note about it.

Comments
Dustan Daniel commented Aug 20 '13, 5:47 a.m.

We have upgraded to 4.0.3 and still face the same problem. 


Jun Wang commented Aug 20 '13, 6:03 a.m.

Do you upgrade the report template after upgrading? For example, go to the Reports->Repor Resources, then check the template 'Requirement Traceability' and click the button on the right to restore the resource from source.

Your answer


Register or to post your answer.