It's all about the answers!

Ask a question

[closed] ERR_CONNECTION_REFUSED after server rename


Joao Ramires (3413) | asked Feb 26 '18, 7:06 a.m.
closed Jul 21, 6:58 a.m. by Ralph Schoon (58.5k23642)

Hi , I'm using 5.0.2 and when creating my staging setup , from a production, one when I try to open:


https://<new_server>/jts/serverRenameStatus I get a ERR_CONNECTION_REFUSED

what should I check ? 

Thanks! 


The question has been closed for the following reason: "Problem is not reproducible or outdated" by rschoon Jul 21, 6:58 a.m.

3 answers



permanent link
James Paulus (20621829) | answered Feb 26 '18, 9:13 a.m.

I would start with the JTS log.


Comments
Joao Ramires commented Feb 27 '18, 1:54 p.m.

JTS log and WAS logs show connection errors for local host (jts-dsv) I've connection refused from the server jts-dsv which my local server.

This is the error from SystemOut.log:

[2/27/18 18:24:35:282 WET] 000000a8 webapp E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [Servlet Error]-[equinoxbridgeservlet]: c om.ibm.team.jfs.app.util.urlmapping.URLMappingException: org.apache.http.conn.HttpHostConnectException: Connection to https://jts-dsv refused at com.ibm.team.jfs.app.util.urlmapping.internal.URLMappingService.getUrlMappingEventFeedStatus(URLMappingService.java:447) at com.ibm.team.jfs.app.util.urlmapping.URLMappingServiceFactory.getMappingEventFeedStatus(URLMappingServiceFactory.java:80)


permanent link
Donald Nong (14.4k314) | answered Feb 27 '18, 1:13 a.m.

You should just treat it as a new server and check connectivity to IP address and port. I suspect your application server may not even start up properly.


Comments
Joao Ramires commented Feb 27 '18, 4:16 a.m.

the App Server (WebSphere) starts ok , I've ccm and jts running in "green status" I can ping the server and I have port 9443 listenning . Is there a way to disable SSL ?


Donald Nong commented Feb 27 '18, 8:46 p.m.

Disabling SSL is not the right way to resolved the issue. If the WAS profile is listening at port 9443 and the public URI uses 443 (default SSL port), it means that there is a reverse proxy in your environment. Have you verified that the reverse proxy is up and running? Can you connect to jts-dsv:443 using telnet or openssl?


Joao Ramires commented Feb 28 '18, 5:35 a.m. | edited Feb 28 '18, 5:37 a.m.

hmm my network skills don't permit me to check if reverse proxy is up and running... I need to talk with AIX admin guy. Meanwhile can I do anything else? 

[axdsv01:joao:/home/joao:] telnet jts-dsv 443 Trying... telnet: connect: A remote host refused an attempted connect operation. [axdsv01:joao:/home/joao:] telnet jts-dsv 9443 Trying... Connected to axdsv01.


1
Donald Nong commented Mar 01 '18, 1:50 a.m.

Your test result proves that port 443 is not open, and that is exactly why you got the ERR_CONNECTION_REFUSED message in the first place. You should check how the production is configured. There should be a reverse proxy, or the application server (Tomcat?) is listening at port 443 instead of 9443. In either case, you need to make necessary changes to allow the applications to be accessed via port 443.


permanent link
Jessica Martin (11) | answered Jul 21, 5:35 a.m.
edited Jul 21, 7:00 a.m. by Ralph Schoon (58.5k23642)

 I think this tutorial can help you to solve this error - blog link removed by Admin


Comments
Ralph Schoon commented Jul 21, 7:00 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

No, probably not, but thank you. The issue is because the server seems to not be connected to the port. It is outdated so I close it. I am not sure if this is spam. It matches all patterns, so I will invalidate the link.