It's all about the answers!

Ask a question

Can't change any attribute on a resoluted workitem


pere irazusta (2062120) | asked Mar 06 '12, 9:57 a.m.
Hi,

I'm trying to change an already resoluted workitem, but when i try to change any attribute i get an error saying that this item has readonly permissions.

I'm using an Administrator user ( with all Jazz... boxes checked), administrator of the PA and administrator rolle.

Any idea on how to change any attribute? Or how to 'unresolve' it?


Thanks!

Pere

4 answers



permanent link
David Olsen (5237) | answered Mar 06 '12, 7:16 p.m.
JAZZ DEVELOPER
On 3/6/2012 7:10 AM, pirazust wrote:
I'm trying to change an already resoluted workitem, but when i try to
change any attribute i get an error saying that this item has
readonly permissions.

I'm using an Administrator user ( with all Jazz... boxes checked),
administrator of the PA and administrator rolle.

Any idea on how to change any attribute? Or how to 'unresolve' it?

Being an administrator gives you permission to change the project area
itself. But it does not give you any extra permissions when it comes to
changing work items or other things within the project area. For that,
you need to be a member of the team area that owns the work item (or of
a parent team area or the parent project area) and have a role that has
permission to make the change.

Since you are an administrator for the project, you have the power to
edit the project area, adding yourself as a member with the correct
role, or changing the permissions so that everyone can change work
items. Then you would be able to make the changes that you want. But
the owner of the project area might get upset if did that. Depending on
your organization, it might be better to find someone who has permission
to change that work item.

--
David Olsen | IBM Rational | Beaverton, Oregon

permanent link
pere irazusta (2062120) | answered Mar 07 '12, 10:02 a.m.
Hi David,

Thanks for your reply!

When I said that I had Admin privileges, I meant that I was Administrator on the PA, and the team area associated from where I 'm trying to change the resolution workitem.


I'm also member in the associated team area and have all the permision boxes checked (both PA and TA configuration ).

Any idea on how to solve this?

Thanks.

permanent link
David Olsen (5237) | answered Mar 07 '12, 7:49 p.m.
JAZZ DEVELOPER
On 3/7/2012 7:10 AM, pirazust wrote:
When I said that I had Admin privileges, I meant that I was
Administrator on the PA, and the team area associated from where I 'm
trying to change the resolution workitem.

I'm also member in the associated team area and have all the permision
boxes checked (both PA and TA configuration ).

Being an administrator of the project area gives you the ability to save
the project area itself, but it does not give you any extra permissions
when it comes to changing work items. That is controlled by the roles
that you have in the various team areas and project area. No amount of
administrator privileges will get you around the need to have the
correct role assignments.

I'm not entirely sure what is preventing you from changing the work
item. But my best guess is that it is an operation behavior rather than
a permission. Under the Operation Behavior section, look for the Work
Items > Save Work Item (server) entry. Does it have the Prevent Editing
precondition selected for any of the roles in any of the relevant team
areas? If so, then you will have to edit or remove that precondition,
or give yourself a role that avoids that precondition, if you want to
change the work item. (I have never used the Prevent Editing
precondition, so I don't know if it could cause your issue. But it
seems like the most likely candidate to me.)

--
David Olsen | IBM Rational | Beaverton, Oregon

permanent link
pere irazusta (2062120) | answered Mar 08 '12, 3:47 a.m.
Bingo!

You are completely wrigth. It was a precondition 'Disable edition' that depended on the state of the workitem.

I just disabled it to make the changes (as the owner of the workitem requested me ), and enabled it again.

Thanks David!

Your answer


Register or to post your answer.