Jazz Forum Welcome to the Jazz Community Forum Connect and collaborate with IBM Engineering experts and users

cmd line adapter is not workin on AIX

Does the command line adapter work on AIX', and if not what can we change to make it work on AIX machines

We are using AIX for running adapater and have RQM server set up on windows.


Error Mesg:

# ./start.sh -repository https://9.124.41.36:9443/jazz -user administrator -password welcome123 -adapterId pap


Adapter is reconnecting. Using saved configuration information from Config.ini
Successfully created an HTTP client
The adapter failed to connect to the server
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:391)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:252)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:239)
at java.net.Socket.connect(Socket.java:556)
at java.net.Socket.connect(Socket.java:504)
at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:403)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:521)
at com.ibm.net.ssl.www2.protocol.https.b.<init>(b.java:143)
at com.ibm.net.ssl.www2.protocol.https.b.a(b.java:41)
at com.ibm.net.ssl.www2.protocol.https.c.getNewHttpClient(c.java:29)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:790)
at com.ibm.net.ssl.www2.protocol.https.c.connect(c.java:67)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:959)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
at java.net.HttpURLConnection.getResponseMessage(HttpURLConnection.java:445)
at com.ibm.net.ssl.www2.protocol.https.a.getResponseMessage(a.java:84)
at com.ibm.rqm.integration.client.clientlib.RQMConnectionHelper.getFromServer(RQMConnectionHelper.java:523)
at com.ibm.rqm.integration.client.clientlib.RQMConnectionHelper.login(RQMConnectionHelper.java:200)
at com.ibm.rqm.adapter.library.data.ServerInformation.login(ServerInformation.java:131)
at com.ibm.rqm.adapter.library.data.NewRequester.<init>(NewRequester.java:102)
at com.ibm.rqm.adapter.library.data.RQMAdapter.<init>(RQMAdapter.java:44)
at com.ibm.rqm.adapter.commandline.QMCommandLineAdapter.<init>(QMCommandLineAdapter.java:65)
at com.ibm.rqm.adapter.commandline.QMCommandLineAdapter.main(QMCommandLineAdapter.java:160)
Failed to save configuration file for the command line adapter
com.ibm.rqm.adapter.library.data.AdapterException:
at com.ibm.rqm.adapter.library.data.AdapterException.<clinit>(AdapterException.java:27)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:196)
at com.ibm.rqm.adapter.library.data.ServerInformation.login(ServerInformation.java:143)
at com.ibm.rqm.adapter.library.data.NewRequester.<init>(NewRequester.java:102)
at com.ibm.rqm.adapter.library.data.RQMAdapter.<init>(RQMAdapter.java:44)
at com.ibm.rqm.adapter.commandline.QMCommandLineAdapter.<init>(QMCommandLineAdapter.java:65)
at com.ibm.rqm.adapter.commandline.QMCommandLineAdapter.main(QMCommandLineAdapter.java:160)
Failed to log in to server at https://9.124.41.36:9443/jazz. Please check the repository URL https://9.124.41.36:9443/jazz, user name administrator and its password and try again. Make sure that the Server is available.

0 votes



One answer

Permanent link
I haven't tried on AIX but I don't see any reason it should work on AIX. I have ran the Command-line adapter on Linux several times and it worked fine.

Here's what comes to mind:

1) Make sure there isn't a firewall on the adapter machine that would block outbound HTTPS connections.
2) From the adapter machine open the browser and make sure you can log into the RQM server.
3) Make sure the java version that the adapter is using is 1.5 or higher. Just type "java -version" on the command line where you are starting the adapter.
4) Try deleting the Config.ini file that is in your adapter directory and restart adapter.
5) I assume you're not on an early release of RQM 3.0, if so the URL should be /rqm not /jazz.

0 votes

Your answer

Register or log in to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.

Search context
Follow this question

By Email: 

Once you sign in you will be able to subscribe for any updates here.

By RSS:

Answers
Answers and Comments
Question details

Question asked: Jun 10 '10, 8:05 a.m.

Question was seen: 8,224 times

Last updated: Jun 10 '10, 8:05 a.m.

Confirmation Cancel Confirm