It's all about the answers!

Ask a question

DOORS Next 7 Import .archive file


Sean F (1.3k12454) | asked Jun 23 '20, 1:17 p.m.
How do you import an archive file in DN7?

In previous DNG versions archives of projects could be created by creating an archive in the database and then downloading it as a .archive file

This .archive file could be uploaded to create a copy of the project on another server.

When trying to upload a .archive on DN7 it says 'file must be a zip file'

If I change the .archive extension to a .zip extension it says

'Error importing template: version.txt must contain the export format version.'

When I unzip the old .archive file using 7Zi[p it contains many folders but it does not contain any 'version' file

Accepted answer


permanent link
Ian Barnard (765612) | answered Jun 24 '20, 5:43 a.m.
JAZZ DEVELOPER
edited Jun 24 '20, 8:21 a.m.

 Hi Sean


AFAICT archives are unchanged in 7.0 - I've just created/downloaded an archive from 6.0.5 and uploaded into 7.0 with no problem. I changed the extension to .zip and that worked too (after deleting the template from first upload).

IIRC I've seen an error 'file must be a zip file' one time when I extracted a .archive then re-zipped it - it won't upload to DN. Or perhaps the .archive is corrupted.

Can you re-download it and try with a fresh .archive?

HTH
Ian

Sean F selected this answer as the correct answer

One other answer



permanent link
Sean F (1.3k12454) | answered Jun 24 '20, 1:14 p.m.
Thanks for the suggestion Ian
The original archive was taken in March 2019 when I think the customer was running 6.0.3 or something like that.
I went back to the same database which is now running 6.0.6.1 and took another archive.
I changed the extension from .archive to .zip and it worked.
A bit odd that the updated importer does not give the user any clue that the extension can and must be changed when it encounters a .archive extension. I think this is likely to be a frequent occurrence for upgrading users with legacy archives..
Or would have been simpler if the importer has simply accepted the .archive extension for backwards compatibility.
Also would be curious to know what the most recent non-compatible version is.

Customers may need to be made aware that there is an incompatibility in case they try to go from 6.0.3 straight to 7 and are relying on archive files for some legacy data.


Comments
Ian Barnard commented Jun 24 '20, 3:04 p.m.
JAZZ DEVELOPER

Hi Sean


I don’t recognize what you mean about changing the file extension to .zip - that’s not needed. It downloads as .archive and uploads as .archive. Or it still uploads if you change .archive to .zip, but that’s not mandatory.

If you’re using Windows you might want to check if displaying file extensions is enabled, as sometimes in Explorer it helpfully hides extensions it knows about.

Regards
Ian


Sean F commented Jun 25 '20, 11:55 a.m.
Thanks Ian.

I have just realised that I was initially in the wrong spot. I was on the process templates page instead of the project templates page when i tried the first time..

Doh!

Your answer


Register or to post your answer.