It's all about the answers!

Ask a question

RTC Shell windows unistall command


Steen Larsen (315) | asked Feb 10, 10:15 a.m.

 Hi


I have a workstation with RTC Shell windows integration (v5.0.1) in a strange condition.

RTC Shell is installed and running, but need to be uninstalled.

Problem is, that Installation Manager don't know of its existence. 
RTC Shell is not at all mentioned in Installation Manager Registry.

Is there a workaround, for uninstall RTC Shell using a command?
Any other safe workaround, is also appreciated.

Thanks...
Steen Larsen

Accepted answer


permanent link
Priyadarshini Gorur (3013) | answered Feb 13, 2:12 a.m.
JAZZ DEVELOPER
Hi Steen,

So, we tried it and it works.

  1. Run all the *uninstall.reg files in the Shell installation\bin folder:
    PackageInitializer_uninstall.reg
    PendingChangesExtn_uninstall.reg
    RegLocation_uninstall.reg
    RepositoryConnectionsExtn_uninstall.reg
    RTCContextMenu_uninstall.reg
    RTCIconOverlayExtension_uninstall.reg
    RTCPropertySheetExtension_uninstall.reg
  2. Restart machine
  3. Delete the installation folder
  4. Installation Manager should allow you to install a new version of Shell to a new package group
Steen Larsen selected this answer as the correct answer

Comments
1
Steen Larsen commented Feb 13, 9:23 a.m.
Perfect Priyadarshini

Worked like a charm.

Thanks...
Steen

4 other answers



permanent link
Priyadarshini Gorur (3013) | answered Feb 11, 10:24 a.m.
JAZZ DEVELOPER
Hi Steen

That sure seems strange. Is it possible that you installed RTC Shell as administrator, but now running Installation Manager in user mode than in admin mode? If that is the case, the user mode Installation Manager may not list the globally installed programs.

- EWM Shell team

permanent link
Steen Larsen (315) | answered Feb 12, 2:01 a.m.
Hi Priyadarshini

It is really strange. 
It's not my own workstation, so I cannot tell what happened prior to this condition.

We have +1000 computers with all kinds of software installed through Installation Manager, and +200 with RTC Shell.
We ALWAYS install as administrator.
So I don't understand how Installation Manager can end in this situation.

If this was an eclipse based tool, I could easily fix this manually.
But in case of RTC Shell, it's a different story. I need a trick to get the software removed.

Thanks

permanent link
Priyadarshini Gorur (3013) | answered Feb 12, 2:17 a.m.
JAZZ DEVELOPER

Hi Steen, probably you can run the *uninstall.reg files shipped in the installation folder\bin as administrator. That should remove the extension's registry entries. After restart, you should be able to delete the installation folder. And hopefully Installation Manager will let you install a new version of RTC Shell. But, let me try it out first and make sure it will work for you. I will update here.


permanent link
Priyadarshini Gorur (3013) | answered Feb 12, 2:22 a.m.
JAZZ DEVELOPER

Your answer


Register or to post your answer.