It's all about the answers!

Ask a question

Microsoft Visual Studio 2017 Not working with RTC 6.0.3 iFix009 Plugin


Evan Edwards (231013) | asked Aug 22 '18, 6:45 p.m.

 I am currently on RTC 6.0.3 iFix009 and I cannot get the Client for Microsoft Visual Studio IDE to work for 2017.  According to the the linked blog article it states that Microsoft Visual Studio 2017 should be support on 6.0.3 iFix005 or later.  Any suggestions to get this working would be very helpful.

Accepted answer


permanent link
Don Yang (7.5k2195130) | answered Aug 23 '18, 12:15 a.m.

Hi Evan

Not sure you have seen the notes in VS readme of the ifix09
==
Note:
This patch cannot be installed directly on Microsoft Visual studio 2017.
For 2017 support please install the TestFix available at
 https://www-945.ibm.com/support/fixcentral/swg/doSelectFixes?options.selectedFixes=6.0.3-Rational-RTC-ifix005_vs2017&downloadMethod=http
before applying this patch. The "2017 Testfix" includes all the fixes that are provided until 6.0.3 iFix 005. For Visual Studio 2017, it is sufficient to apply from 6.0.3 iFix 006 onwards on top of the “2017 Testfix”.
==
so you would need to have 6.0.3-Rational-RTC-ifix005_vs2017 installed fist and then apply the ifix09 on top of it as per the notes for VS 2017.

Evan Edwards selected this answer as the correct answer

Comments
Evan Edwards commented Aug 23 '18, 11:01 a.m.

 Hi Don,


Thank you for your answer it was very helpful.  Just to clarify if I install the 6.0.3-Rational-RTC-ifix005_vs2017 iFix do I have to then update and install the Visual Studio while the system is on that iFix before I can install the latest CLM iFix012 for 6.0.3 version or can I install the ifix005_vs2017 iFix then immediately follow with installing the iFix012?


Don Yang commented Aug 23 '18, 7:52 p.m.

you should be able to install iFix012 on top of ifix005_vs2017 iFix

Your answer


Register or to post your answer.