It's all about the answers!

Ask a question

Conflicting dependency when installing Web, XML and Java EE Development


Staffan Solin (133) | asked Feb 21 '17, 5:56 a.m.

I installed Client for Eclipse 4.2.x IDE (RTC 6.0.2) with help of launchpad.


Next step (step 2. -k) in the tutorial is to "Install new Software"(Web, XML, Java EE Development). When doing this step RTC throws this error: 

Cannot complete the install because of a conflicting dependency.
  Software being installed: JST Web UI 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ (org.eclipse.jst.web_ui.feature.feature.group 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ)
  Software currently installed: IBM Rational Team Concert Buildsystem 2017.2.17.125700 (IBM Rational Team Concert Buildsystem com.ibm.sdp.eclipse.ide 2017.2.17.125700)
  Only one of the following can be installed at once: 
    Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58)
    Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x)
    Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
    Java Development Tools Core 3.8.4.v20130621-1225 (org.eclipse.jdt.core 3.8.4.v20130621-1225)
  Cannot satisfy dependency:
    From: IBM Rational Team Concert Buildsystem 2017.2.17.125700 (IBM Rational Team Concert Buildsystem com.ibm.sdp.eclipse.ide 2017.2.17.125700)
    To: org.eclipse.jdt.R422patch.feature.group [1.0.5]
  Cannot satisfy dependency:
    From: IBM Rational Team Concert Buildsystem 2017.2.17.125700 (IBM Rational Team Concert Buildsystem com.ibm.sdp.eclipse.ide 2017.2.17.125700)
    To: org.eclipse.jdt.feature.group [3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83]
  Cannot satisfy dependency:
    From: Structured Source JSP Model 1.2.304.v201102160550 (org.eclipse.jst.jsp.core 1.2.304.v201102160550)
    To: bundle org.eclipse.jdt.core [3.5.0,3.7.0)
  Cannot satisfy dependency:
    From: JST Web Core 3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz- (org.eclipse.jst.web_core.feature.feature.group 3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz-)
    To: org.eclipse.jst.jsp.core [1.2.304.v201102160550]
  Cannot satisfy dependency:
    From: JST Web UI 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ (org.eclipse.jst.web_ui.feature.feature.group 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ)
    To: org.eclipse.jst.web_core.feature.feature.group [3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz-]
  Cannot satisfy dependency:
    From Patch: org.eclipse.jdt.R422patch.feature.group 1.0.5 Eclipse Java Development Tools 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 (org.eclipse.jdt.feature.group 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83)
    To: org.eclipse.jdt.core [3.8.4.v20130621-1225]

What can I do to solve this conflicting dependency? Is it because im using RTC 6.0.2 instead of 4.0(which was used in the tutorial)?

Also, if I remove "JST WebUI", "Java Server Faces Tool", "Apache myFace trindad...", "Webpage editor" from the software installation, the installation works without conflicts but then I have problems creating .JSP file later on.

Thanks in advance.

Accepted answer


permanent link
Ralph Schoon (55.6k23642) | answered Feb 21 '17, 7:10 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 I would suggest to install Eclipse EE and the necessary XML, WEB tools from the Eclipse downloads page, then install RTC using the P2 install.

Staffan Solin selected this answer as the correct answer

Your answer


Register or to post your answer.