It's all about the answers!

Ask a question

RTC SDK zip's are invalid for 4.0 and 4.0.0.1 on windows 7


Marc Towersap (481711) | asked Feb 18 '13, 2:56 p.m.
I'm trying to download the SDK for RTC 4.0, but when I extract the download, windows 7 says it's an invalid zip. Tried downloading 4.0.0.1, I get the same error.  Trying 4.0.0.2 which is downloading now, but I doubt it will work too.

2 answers



permanent link
sam detweiler (12.5k6189201) | answered Feb 18 '13, 3:15 p.m.
use Winrar or 7zip.. there a number of long filenames that the windows zip cannot handle.

Comments
Marc Towersap commented Feb 18 '13, 3:29 p.m. | edited Feb 19 '13, 1:26 p.m.

I wish the website would tell you this.  I used jar xvf, and yes it does work... grrrr


Marc Towersap commented Feb 18 '13, 3:31 p.m. | edited Feb 19 '13, 1:26 p.m.

What the website really needs is a newbie person who tries to follow the instructions on the website, click on various links and tries to do various things, and based on that newbie's failures, update the website.


Ralph Schoon commented Feb 19 '13, 3:02 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please feel free to suggest this improvement here.


permanent link
Ralph Schoon (61.6k33643) | answered Feb 19 '13, 2:57 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Feb 19 '13, 2:58 a.m.
Marc, you should really look into https://jazz.net/library/article/1000 if you are new to the SDK. It also mentions the issue with windows zip and hints using 7ZIP.

Unfortunately Windows in general has issues with long path names for ages now and it does not seem to get better. Windows is the only OS I have seen these issues with. I gave up using the built in Zip on windows long time ago. 7Zip is the better choice.

If you develop using the SDK, you also want to make sure to pick a folder that is reasonably close to the root, since the long path names of the plugins/features can cause Windows to choke on deleting the files - because of a path length bigger than what Windows assumes as normal.

Finally, you want to avoid to install Jazz Servers into "Program Files" because the folder is virtualized and removes permissions to create files and folders unless you explicitly run "As Administrator". This effect is caused by safety measures Windows imposes to reduce risk.

Comments
Ralph Schoon commented Feb 19 '13, 3:01 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

And be aware if you want to use the repository files that ship with the RTC extensions workshop you have to use exactly the version that it is based upon. You can use the SDK setup procedure with other versions however. I am just using it with 4.0.1 and it works well enough for me.


Marc Towersap commented Feb 19 '13, 7:22 a.m. | edited Feb 19 '13, 1:27 p.m.

Thx for the links! I do wish though that I wouldn't have to google around or have to complain and bug everyone here so y'all could respond with a 'RTM'!! thank you!


Geoffrey Clemm commented Feb 19 '13, 1:28 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hopefully most of the responses you get are of the form "RTPOTM" (read this page of the manual" ... I agree that a simple "RTM" would not be of much use (:-).

Your answer


Register or to post your answer.